XtraBackup MySQL 8Update: Percona XtraBackup 8.0.12 now supports backup and restore processing for versions of MySQL 8.x; previous versions of Percona XtraBackup will not work with MySQL 8.0.20 and higher. More information


On Monday, April 27, 2020, Oracle released the highly anticipated 8.0.20 version of the MySQL database server. This release contains changes to the InnoDB redo log format which breaks compatibility with all currently released versions of the Percona XtraBackup 8.x series.

At this time, there are no known workarounds that will allow any version of Percona XtraBackup 8.x to function properly with MySQL 8.0.20.

We have identified the specific cause of the issue and diligently working towards a new release that will safely solve this issue as soon as possible.

Thank you for your patience.

6 Comments
Oldest
Newest Most Voted
Inline Feedbacks
View all comments
Erik Rothoff Andersson

Any news here? We just upgraded and didn’t realise that xtrabackup would be broken.

Hua Tang

Update: Percona XtraBackup 8.0.12 now supports backup and restore processing for all versions of MySQL up to and including 8.0.20; previous versions of Percona XtraBackup will not work with MySQL 8.0.20 and higher

Does it also support mysql 5.x?

sheetal

Which version of qpress should be used with Percona 8.0.12

sheetal

Is there a qpress github link?