Percona XtraBackup 8.0-3-rc1 Is Available

Percona XtraBackup 8.0-3-rc1 Is Available

PREVIOUS POST
NEXT POST

Percona XtraBackup 8.0Percona is glad to announce the release candidate of Percona XtraBackup 8.0-3-rc1 on October 31 2018. You can download it from our download site and apt and yum repositories.

This is a Release Candidate quality release and it is not intended for
production. If you want a high quality, Generally Available release, use the current stable version (the most recent stable version at the time of writing is 2.4.12 in the 2.4 series).

This release supports backing up and restoring MySQL 8.0 and Percona Server for MySQL 8.0

Things to Note

  • innobackupex was previously deprecated and has been removed
  • Due to the new MySQL redo log and data dictionary formats the Percona XtraBackup 8.0.x versions will only be compatible with MySQL 8.0.x and the upcoming Percona Server for MySQL 8.0.x
  • For experimental migrations from earlier database server versions, you will need to backup and restore and using XtraBackup 2.4 and then use mysql_upgrade from MySQL 8.0.x

Installation

As this is a release candidate, installation is performed by enabling the testing repository and installing the software via your package manager. For Debian based distributions see apt installation instructions, for RPM based distributions see yum installation instructions. Note that in both cases after installing the current percona-release package, you’ll need to enable the testing repository in order to install Percona XtraBackup 8.0.3-rc1.

Improvements

  • PXB-1655:  The --lock-ddl option is supported when backing up MySQL 8

Bugs Fixed

  • PXB-1678:  Incremental backup prepare run with the --apply-log-only option could roll back uncommitted transactions.
  • PXB-1672:  The MTS slave without GTID could be backed up when the --safe-slave-backup option was applied.
PREVIOUS POST
NEXT POST

Share this post

Comment (1)

  • Larry Cable Reply

    Hi Borys,
    I’m having trouble loading xtrabackup in release percona-xtrabackup-8.0.3-Linux-x86_64. I’m getting unsatisfied externals:

    Red Hat Enterprise Linux Server release 7.3 (Maipo)

    [mysqladm@dbvrdd16872:/home/mysqladm/backup/bin] ldd xtrabackup
    ./xtrabackup: /lib64/libstdc++.so.6: version GLIBCXX_3.4.21' not found (required by ./xtrabackup)
    ./xtrabackup: /lib64/libstdc++.so.6: version
    GLIBCXX_3.4.20′ not found (required by ./xtrabackup)
    ./xtrabackup: /lib64/libstdc++.so.6: version CXXABI_1.3.8' not found (required by ./xtrabackup)
    ./xtrabackup: /home/mysqladm/backup/lib/libcrypto.so.1.0.0: version
    OPENSSL_1.0.2′ not found (required by ./xtrabackup)

    What libraries are you using to resolve these externals and where did you get them?

    Thx

    larry_cable@optum.com

    December 3, 2018 at 10:11 am

Leave a Reply