Emergency

New node joins, but is unreachable

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • New node joins, but is unreachable

    Hi There,

    I'm using Percona with Galera version 3.21(r8678538).

    I'm creating a new Percona XtraDB Cluster, but something goes wrong when I add the second node.
    I can bootstrap the first node perfectly, but when the second node is added, I can see the increase of the wsrep_cluster_size
    and wsrep_cluster_conf_id on the first node, but I can't login to the second node.
    Whenever I try to access, I get the message:
    ERROR 2002 (HY000): Can't connect to local MySQL server through socket '/var/lib/mysql/mysql.sock' (2)

    When I run "netstat -ltnp" I can't find any process listening on port 3306 (on the second node):
    $ netstat -ltnp
    Active Internet connections (only servers)
    Proto Recv-Q Send-Q Local Address Foreign Address State PID/Program name
    tcp 0 0 0.0.0.0:111 0.0.0.0:* LISTEN 1/systemd
    tcp 0 0 0.0.0.0:22 0.0.0.0:* LISTEN 877/sshd
    tcp 0 0 0.0.0.0:4567 0.0.0.0:* LISTEN 1530/mysqld
    tcp 0 0 127.0.0.1:25 0.0.0.0:* LISTEN 1029/master
    tcp6 0 0 :::111 :::* LISTEN 1/systemd
    tcp6 0 0 :::22 :::* LISTEN 877/sshd
    tcp6 0 0 ::1:25 :::* LISTEN 1029/master


    But I can see the mysqld process running:
    $ ps aux | grep -imysql
    mysql 1530 0.2 12.8 1154696 450120 pts/0 Sl 21:34 0:00 mysqld --user=mysql --log-error=/var/lib/mysql/error.log
    mysql 1544 0.0 0.0 113492 1968 pts/0 S 21:34 0:00 /bin/bash -ue /bin/wsrep_sst_xtrabackup-v2 --role joiner --address 10.0.1.5 --datadir /var/lib/mysql/data/ --defaults-file /etc/my.cnf --defaults-group-suffix --parent 1530
    mysql 1971 0.0 0.3 171724 12748 pts/0 Sl 21:34 0:00 innobackupex --no-version-check --use-memory=512000 --apply-log /var/lib/mysql/data//.sst

    root 2033 0.0 0.0 112664 992 pts/0 R+ 21:36 0:00 grep --color=auto -i mysql

    At first, I thought that the problem could be the SST still in progress, but my databases are empty and I've waited several minutes but nothing changed.
    Didn't find anything relevant on the log files, no error messages, only warnings.

    Any suggestion on how to solve this, please?

    Thanks!

  • #2
    Just fixed it.
    The problem was a low value for innodb_buffer_pool_size variable on the mysql config file.

    Comment


    • #3
      Can you show us output of:

      Code:
      mysql> SHOW STATUS LIKE 'ws%';
      Also, attach error logs from both nodes.

      Comment

      Working...
      X