error in sst xtrabackup

  • Filter
  • Time
  • Show
Clear All
new posts

  • error in sst xtrabackup


    I get some strange message when I want to perform a sst with xtrabackup.
    The sst failes.

    Get the latest version of Percona XtraBackup, documentation, and help resources:

    140728 15:09:23 innobackupex: Connecting to MySQL server with DSN 'dbi:mysql:;mysql_read_default_file=/etc/mysql/my.cnf;mysql_read_default_group=xtrabackup' as 'sst' (using password: YES).
    140728 15:09:23 innobackupex: Connected to MySQL server
    140728 15:09:23 innobackupex: Executing a version check against the server...
    140728 15:09:23 innobackupex: Done.
    IMPORTANT: Please check that the backup run completes successfully.
    At the end of a successful backup run innobackupex
    prints "completed OK!".

    innobackupex: Using mysql server version 5.5.34

    innobackupex: Created backup directory /tmp

    140728 15:09:23 innobackupex: Starting ibbackup with command: xtrabackup_55 --defaults-file="/etc/mysql/my.c
    nf" --defaults-group="mysqld" --backup --suspend-at-end --target-dir=/mnt/ramdisk --tmpdir=/mnt/ramdisk --stream=tar
    innobackupex: Waiting for ibbackup (pid=31739) to suspend
    innobackupex: Suspend file '/mnt/ramdisk/xtrabackup_suspended_2'

    xtrabackup_55 version 2.1.8 for Percona Server 5.5.35 Linux (x86_64) (revision id: undefined)
    xtrabackup: uses posix_fadvise().
    xtrabackup: cd to /var/lib/mysql
    xtrabackup: using the following InnoDB configuration:
    xtrabackup: innodb_data_home_dir = ./
    xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
    xtrabackup: innodb_log_group_home_dir = ./
    xtrabackup: innodb_log_files_in_group = 2
    xtrabackup: innodb_log_file_size = 209715200
    xtrabackup: using O_DIRECT
    >> log scanned up to (4370789295766)
    140728 15:09:23 InnoDB: Operating system error number 24 in a file operation.
    InnoDB: Error number 24 means 'Too many open files'.
    InnoDB: Some operating system error numbers are described at
    InnoDB: http://dev.mysql.com/doc/refman/5.5/...ror-codes.html
    InnoDB: Error: could not open single-table tablespace file
    InnoDB: ./aswoconfig/sphinx_config_types.ibd!
    InnoDB: We do not continue the crash recovery, because the table may become
    InnoDB: corrupt if we cannot apply the log records in the InnoDB log to it.
    InnoDB: To fix the problem and start mysqld:
    InnoDB: 1) If there is a permission problem in the file and mysqld cannot
    InnoDB: open the file, you should modify the permissions.
    InnoDB: 2) If the table is not needed, or you can restore it from a backup,
    InnoDB: then you can remove the .ibd file, and InnoDB will do a normal
    InnoDB: crash recovery and ignore that table.
    InnoDB: 3) If the file system or the disk is broken, and you cannot remove
    InnoDB: the .ibd file, you can set innodb_force_recovery > 0 in my.cnf
    InnoDB: and force InnoDB to continue crash recovery here.
    innobackupex: Error: The xtrabackup child process has died at /usr//bin/innobackupex line 2622.
    Have someone a idea for me ?


  • #2
    Have you tried xtrabackup itself only by donner node?

    > InnoDB: Error number 24 means 'Too many open files'.
    Last edited by taka-h; 07-28-2014, 06:54 PM.


    • #3
      I tried it by donor mode.
      But I solved it. I set the sst session to
       ulimit -n 1048576


      • #4

        Would you confirm 2 more configuration?

        1. open-files-limit (my.cnf)

        2. please confirm my.cnf configuration of wsrep_sst_method (should be xtrabackup-v2)

        If following is repeatable I don't have any idea.
        • manual back up on donor node by xtrabackup succeed
        • sst fail by 'Too many open files' error while backing up
        thank you