percona cluster 5.6 install problem

  • Filter
  • Time
  • Show
Clear All
new posts

  • percona cluster 5.6 install problem

    When Installing Percona XtraDB Cluster on Ubuntu 12.04 LTS - fresh OS install - I get the following errors:

    Unpacking percona-xtradb-cluster-client-5.6 (from .../percona-xtradb-cluster-client-5.6_5.6.15-25.2-645.precise_amd64.deb) ...
    dpkg: error processing /var/cache/apt/archives/percona-xtradb-cluster-client-5.6_5.6.15-25.2-645.precise_amd64.deb (--unpack):
    trying to overwrite '/usr/share/man/man1/mysql.1.gz', which is also in package mysql-client-core-5.5 5.5.32-0ubuntu0.12.04.1
    dpkg-deb: error: subprocess paste was killed by signal (Broken pipe)

    I have three identical Dell servers, and did frexh 12.04 installs on all three. Followed exactly the same install process as on

    Two of the servers failed with the error above and the third worked!!!

    I tried fixing it with apt-get install -f but keep getting the same error.

  • #2
    Please file a bug!


    • #3
      mmmmm. launchpad. ok. bug reported.
      Last edited by francoisstark; 01-22-2014, 09:02 AM.


      • #4
        In the end, it was not a bug. The problem was caused by an old version of /var/mysql/my.cnf, containing a few bad settings. Notably, I could not get percona 5.6 to start with

        pid-file = /var/run/mysqld/mysqld.pid

        and these settings also caused problems for percona 5.6:

        query_cache_limit = 1M
        query_cache_size = 16M

        After removing these lines all seems well. 3-system Cluster synced.

        I hope this helps somebody else. Please be aware that apt-get remove --purge and the re-installing with apt-get install does not alter the my.cnf file and you could still have old settings...