sh: 1: xtrabackup_55: not found

  • Filter
  • Time
  • Show
Clear All
new posts

  • sh: 1: xtrabackup_55: not found

    Hello I installed Ubuntu 12.04.2 LTS on a fresh box. This automatically also installed MySQL 5.5.29.

    I installed percona-xtrabackup-2.0.6-521.tar.gz and put the files in /usr/bin.

    But innobackupex is giving an error: "sh: 1: xtrabackup_55: not found"


    david@server1:/usr/bin$ sudo innobackupex --user=root --password=123 /home/david/dbb/
    [sudo] password for david:

    InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
    and Percona Ireland Ltd 2009-2012. All Rights Reserved.

    This software is published under
    the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

    130401 12:17:04 innobackupex: Starting mysql with options: --password=xxxxxxxx --user='root' --unbuffered --
    130401 12:17:04 innobackupex: Connected to database with mysql child process (pid=1488)
    130401 12:17:10 innobackupex: Connection to database server closed
    IMPORTANT: Please check that the backup run completes successfully.
    At the end of a successful backup run innobackupex
    prints "completed OK!".

    innobackupex: Using mysql Ver 14.14 Distrib 5.5.29, for debian-linux-gnu (x86_64) using readline 6.2
    innobackupex: Using mysql server version Copyright (c) 2000, 2012, Oracle and/or its affiliates. All rights reserved.

    sh: 1: xtrabackup_55: not found
    innobackupex: fatal error: no 'mysqld' group in MySQL options


    The files are present and executable:

    david@server1:/usr/bin$ ls -l grep inno*
    ls: cannot access grep: No such file or directory
    -rwxr-xr-x 1 root root 108823 Mar 19 14:24 innobackupex
    lrwxrwxrwx 1 david david 12 Mar 19 14:24 innobackupex-1.5.1 -> innobackupex
    -rwxr-xr-x 1 root root 10096 Jan 16 17:24 innochecksum
    -rwxr-xr-x 1 root root 400192 Jan 16 17:24 innotop
    david@server1:/usr/bin$ ls -l grep xtra*
    ls: cannot access grep: No such file or directory
    -rwxr-xr-x 1 root root 9799993 Mar 19 14:21 xtrabackup
    -rwxr-xr-x 1 root root 8361704 Mar 19 14:24 xtrabackup_51
    -rwxr-xr-x 1 root root 12699861 Mar 19 14:15 xtrabackup_55


    Path is correct:

    david@server1:/usr/bin$ echo $PATH
    /usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin :/usr/games


    I get the same results if I run

    sudo innobackupex
    sudo ./innobackupex


    Any ideas?

  • #2
    Maybe the problem is not related but I would like to start debugging this error message:

    innobackupex: fatal error: no 'mysqld' group in MySQL options

    Where is your my.cnf located? Can you share it?



    • #3
      Duplicate: http://dba.stackexchange.com/questions/39009/ubuntu-mysql-pe rcona-xtrabackup-gives-error-sh-1-xtrabackup-55-not-found


      • #4
        I figured out the solution, Ubuntu server was 64 bit, but I had installed Percona's 32 bit version. Installing Percona's 64 bit version fixed the problem.


        • #5
          hi david ,
          i have changed the percona version 32 bit to 64 bit but i still getting the same error. please somebody help me