innobackupex :- corrupting tables

  • Filter
  • Time
  • Show
Clear All
new posts

  • innobackupex :- corrupting tables

    Hello all,

    In my continued endeavor of setting up replication using "Xtrabackup" i have learnt that my replication on slave does not start , REASON being tables getting corrupted, that were being backed up using this command :-

    innobackupex --user=yourDBuser --password=MaGiCdB1 /path/to/backupdir

    Mentioned On this page :-


    I learnt about it after i ran the "mysqlcheck" on my slave server.

    Can any one tell me, HOW CAN I AVOID such a data corruption during backup creation ?

    Please assist ?

    Thank you

  • #2
    Which version of MySQL is your master? Which version of MySQL is your slave?

    If they are a different version you will need to run the mysql_upgrade utility after the import into the slave.

    The slave can always be a newer version than the master, but not the other way around.

    That's about all I can imagine without further details.

    Are you capturing the output from the backup into any kind of log file?


    • #3
      Highly appreciate your turn around David,

      I have managed to reslove this issue, by upgrading the slave server with "percona mysql server" which i did not have earlier, I was infact using plain mysql that comes with the linux distro ...

      Since you have replied to my issue above, Can you let me know if it is mandatory to have Percona on both, master and slave servers for replication to happen ?

      Thank you for your time.


      • #4
        I'm not sure about Percona on both - I've never set that up before.

        I try to never use the MySQL that comes with the distributions because then you are at the mercy of the distro maintainer to make sure it's up to date with the latest security patches. I'd rather download management packages straight from MySQL. That way you can at least check the MD5 sums.

        Percona does seem to have its preferred configurations - which all seem to be excellent configurations - but I do know that you will run into fewer problems if you have the slave and the master of any MySQL server running the same versions with identical configurations (well, except for the server_id and other replication configurations of course).

        I'm glad you got it worked out.


        • #5
          Package managers of Linux distros check the integrity of downloaded packages automatically, so no need for manual MD5 checking


          • #6
            Thank you for that information gmouse.

            How can I prove that this happens to my auditors?

            Why are the versions in the distros often not the very latest GA from MySQL?

            Thank you -


            • #7
              The answers depend on the linux distro that you use


              • #8
                Thanks - our servers run primarily RHEL, CentOS and Ubuntu.


                • #9
                  Let me focus on Ubuntu Pricise (LTS).
                  "apt-get update" gets a list of packages via http://us.archive.ubuntu.com/ubuntu/dists/precise/
                  The integrity of the Release file is guaranteed via the GPG-file. The release-file contains names of package files with their md5sum. Each package file contains md5sums (and sha1 and sha256) of the packages themselves, and at least the md5sum is actually checked.

                  I think Ubuntu never makes new major releases available to released Ubuntu versions. That is why MySQL 5.6 (GA) is unavailable in 12.04. For updates within the 5.5 branch, I think the focus is on security updates. Ubuntu Precise currently has MySQL 5.5.29 that was released in December 21 2012. As you can see, Uubuntu got the update on January 16 2013. I am not sure whether the Ubuntu update from December 7 actually patched the security flaw before MySQL.


                  • #10
                    Yes - I've noticed that Ubuntu does do the best job of providing the latest versions of MySQL of the bunch.

                    I also see people installing packages named something like 'MySQL Version 5.1.97 Marvin's Release' on CentOS

                    Unfortunately, only two out of my couple hundred systems use Ubuntu.

                    But thank you for that information - maybe I can use it to get future MySQL server installations to use Ubuntu.