InnoDB: No valid checkpoint found.

  • Filter
  • Time
  • Show
Clear All
new posts

  • InnoDB: No valid checkpoint found.

    Hello, i experience the following error, how to resolve this issue:

    xtrabackup: Target instance is assumed as followings.xtrabackup: innodb_data_home_dir = ./xtrabackup: innodb_data_file_path = ibdata1:10M:autoextendxtrabackup: innodb_log_group_home_dir = ./xtrabackup: innodb_log_files_in_group = 2xtrabackup: innodb_log_file_size = 209715200xtrabackup: using O_DIRECTInnoDB: No valid checkpoint found.InnoDB: If this error appears when you are creating an InnoDB database,InnoDB: the problem may be that during an earlier attempt you managedInnoDB: to create the InnoDB data files, but log file creation failed.InnoDB: If that is the case, please refer toInnoDB: http://dev.mysql.com/doc/refman/5.1/en/error-creating-innodb.htmlinnobackupex: Error: ibbackup child process has died at /usr/bin/innobackupex line 374.

  • #2
    Can you provide the version of xtrabackup you are using and the complete command you used to run xtrabackup? Thank you.


    • #3
      Yes sure.
      here is the command i ran:

      innobackupex --defaults-file=/etc/my.cnf --user=***** --password=***** --databases=database12 /backup

      xtrabackup version:

      xtrabackup version 2.0.2 for Percona Server 5.1.59 unknown-linux-gnu (x86_64) (revision id: 461)

      mysql version:

      Server version: 5.1.63-cll MySQL


      • #4
        So what is the solution? Believe me, i read all i could found on Google about this error message, but couldn't find help.


        • #5
          This is an InnoDB error, not an xtrabackup error. Did you review the suggestions at http://dev.mysql.com/doc/refman/5.1/en/error-creating-innodb .html?

          Did you recently migrate or restore this MySQL instance? You may want to double-check the methods you used.


          • #6
            I knew it was a problem with innodb, but i saw another forum here, with people with this very same problem. I also checked several possible solutions adviced on "dev.mysql.com". But none of them worked. HOWEVER today i gave it another shot, and now it is clear, that innodb engine had a serious problem. I restored a backup about 1 month ago, and strangely it screwed up everything, that's why innodb was NOT even running. So if people has this issue:
            -check if innodb works or not
            -check if innodb log files are corrupt or not (backup, and delete them, and restart mysql)
            -if innodb log files or OK, then your innodb data files might be corrupt, but that is a complex issue, so google on it