xtrabackup 2.0 GA not working on 5.1 installs?

  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup 2.0 GA not working on 5.1 installs?

    I recently decided to try upgrading to xtrabackup 2.0 on one of my servers. However, it doesn't appear that --stream=tar appears to work properly, anymore. Here is my command line:

    innobackupex-1.5.1 --user --password --stream=tar ./ > backup.test2.tar

    The output that this gives out is:

    InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oy
    and Percona Inc 2009-2012. All Rights Reserved.

    This software is published under
    the GNU GENERAL PUBLIC LICENSE Version 2, June 1991.

    120406 16:05:34 innobackupex-1.5.1: Starting mysql with options: --password=xxxxxxxx --user='backup' --unbuffered --
    120406 16:05:34 innobackupex-1.5.1: Connected to database with mysql child process (pid=29516)
    120406 16:05:40 innobackupex-1.5.1: Connection to database server closed
    IMPORTANT: Please check that the backup run completes successfully.
    At the end of a successful backup run innobackupex-1.5.1
    prints "completed OK!".

    innobackupex-1.5.1: Using mysql Ver 14.14 Distrib 5.1.53, for unknown-linux-gnu (x86_64) using readline 5.1
    innobackupex-1.5.1: Using mysql server version Copyright (c) 2000, 2010, Oracle and/or its affiliates. All rights reserved.

    innobackupex-1.5.1: Created backup directory /root/dbbackup_xtra
    120406 16:05:40 innobackupex-1.5.1: Starting mysql with options: --password=xxxxxxxx --user='backup' --unbuffered --
    120406 16:05:40 innobackupex-1.5.1: Connected to database with mysql child process (pid=29541)
    120406 16:05:42 innobackupex-1.5.1: Connection to database server closed

    120406 16:05:42 innobackupex-1.5.1: Starting ibbackup with command: xtrabackup --backup --suspend-at-end --target-dir=/tmp --stream=tar
    innobackupex-1.5.1: Waiting for ibbackup (pid=29547) to suspend
    innobackupex-1.5.1: Suspend file '/tmp/xtrabackup_suspended'

    xtrabackup version 2.0.0 for Percona Server 5.1.59 unknown-linux-gnu (x86_64) (revision id: 417)
    xtrabackup: uses posix_fadvise().
    xtrabackup: cd to /var/lib/mysql
    xtrabackup: Target instance is assumed as followings.
    xtrabackup: innodb_data_home_dir = ./
    xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
    xtrabackup: innodb_log_group_home_dir = ./
    xtrabackup: innodb_log_files_in_group = 2
    xtrabackup: innodb_log_file_size = 2097152000
    xtrabackup: using O_DIRECT
    120406 16:05:42 InnoDB: Warning: allocated tablespace 96, old maximum was 9
    >> log scanned up to (1733864492822)
    archive_write_header() failed.
    [01] xtrabackup: error: cannot open the destination stream for ibdata1
    [01] xtrabackup: Error: xtrabackup_copy_datafile() failed.
    [01] xtrabackup: Error: failed to copy datafile.
    innobackupex-1.5.1: Error: ibbackup child process has died at /usr/bin/innobackupex-1.5.1 line 371.

    If I remove the --stream=tar option, then everything works fine.
    Everything did work fine under previous versions of xtrabackup, and I was able to downgrade to xtrabackup 1.6.6 and have everything work properly.

  • #2
    Please read the documentation for the updated version; there are large and important changes.


    • #3
      Ok, then I'm missing something obvious here. Looking at the --help page for innobackupex, I see:

      --stream=[tar|. . .]
      This option specifies the format in which to do the streamed backup.
      The option accepts a string argument. The backup will be done to
      STDOUT in the specified format. Currently, the only supported
      formats are tar and xbstream. This option is passed directly to
      xtrabackup's --stream option.

      Same type of thing located at:
      http://www.percona.com/doc/percona-xtrabackup/innobackupex/s treaming_backups_innobackupex.html

      I don't otherwise see any docs that are specific for xtrabackup 2.0.0. What am I missing here?


      • #4
        I think the problem is there is no tar4ibd in the 2.x package