xtrabackup problems

  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup problems

    I'm a noob at this so please bear with me.

    1. Installed xtrabackup via the yum repos and from what I noticed, it replaced my mysqld server. Gave me quite a nightmare thinking I'd loose my data but it's all good. I only have one complain now ... mysqld logs is not showing up now. I have the correct config in my.cnf pointing to /var/log/mysqld.log but it's not writing there. How do I fix it?

    2. I went ahead with the innobackup script and gzip it up and here's what I saw after several long hours. Should I be concerned that the backup wasn't done properly? The rest of the backups above looks fine with only that last message which I think could be ignored as it's just trying to unlock the tables. It could cause some problems with my current db? Thanks in advance

    innobackupex-1.5.1: Resuming ibbackup

    xtrabackup: The latest check point (for incremental): '227719398386'
    >> log scanned up to (227719401863)
    xtrabackup: Transaction log of lsn (227704425299) to (227719401863) was copied.
    innobackupex-1.5.1: Error: mysql child process has died: ERROR 2006 (HY000) at line 13: MySQL server has gone away
    while waiting for reply to MySQL request: 'UNLOCK TABLES;' at /usr/bin/innobackupex-1.5.1 line 479.

  • #2
    I am not sure why it replaced your mysqld, that should not happen unless you mistakenly installed the wrong thing or there was a dependency mixup or something.

    The error message you mentioned has been solved several times on the mailing list. Can you search for that? If you find a link to the thread, can you post it here for future reference?


    • #3
      osensei wrote on Wed, 16 June 2010 05:46

      I'm a noob at this so please bear with me.

      1. Installed xtrabackup via the yum repos and from what I noticed, it replaced my mysqld server.

      Sounds like a bug. XtraBackup rpm does really have a dependancy on mysql-client, but not a server of course.

      If it is possible, could you please show output of "rpm -qa | grep -i -e mysql -e percona" before and after XtraBacukup installation?

      What is you operation system? Are there any additional repos installed on the system?



      • #4
        I am using CentOS 5.3 64bit

        This is after installation cos it's already installed. I have the basic repo, rpmforge and percona

        # rpm -qa | grep -i -e mysql -e percona

        Which is the best painless way of installing it? The first server went smooth with repo way. The 2nd replaced my mysqld. I tried on 3rd server with rpm and I got this

        # rpm -ivh xtrabackup-1.2-22.rhel5.x86_64.rpm
        warning: xtrabackup-1.2-22.rhel5.x86_64.rpm: Header V3 DSA signature: NOKEY, key ID cd2efd2a
        error: Failed dependencies:
        mysql-client is needed by xtrabackup-1.2-22.rhel5.x86_64


        Thanks in advance )


        • #5
          First off, I think your RPMs are inconsistent. Based on your first post, you would've been using packages on the highperf-5.0.87 release and when you installed XtraBackup you agreed on installing the dependencies.

          Is there a reason you are still on 5.0.87? If upgrading is a possible option for you, you can proceed with the following steps TAKING BACKUPS beforehand )

          If not, try to see what packages will match you 5.0.87 release by running `yum list|grep ercona`

          You should try removing these 2 items first:

          And replace them with these:

          Then try installing XtraBackup again.
          Our documentation has a lot of answers about common questions on Percona software, have you checked there before posting that question here? http://www.percona.com/forums/core/i...lies/smile.png

          Join us at the annual Percona Live MySQL Users Conference - http://www.percona.com/live/mysql-conference-2014/