Buy Percona ServicesBuy Now!

Can't install xtrabackup-24 in Debian 9 or 10

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Can't install xtrabackup-24 in Debian 9 or 10

    I'm seeing dependency errors, as the official debian packages are dependent on libcurl3 which is obsolete, as curl is presently dependent upon libcurl4.

    I attempted to solve this by compiling from source and ran into similar dependency issues.

    Is there a solution presently, to install XtraBackup 2.4 on an up-to-date Debian 9 system or Debian 10 (current stable)?

  • #2
    Hi pridetechdesign thanks for reporting that you found issues with this install. I just had our packaging engineers check out this install and they found everything worked well.
    Could you provide some more information please?
    For example:
    • where you are grabbing the code from
    • any errors and error logs that are getting written
    • specific versions of Percona Xtrabackup you are using, the latest version can be found here https://www.percona.com/downloads/Pe...up-2.4/LATEST/
    • what database you are planning to back up (just want to confirm versions of the database software with you and the team too, in case there's anything to be aware of)
    • the command (s) you are using to compile
    Armed with this information, I'm sure we can find someone to help you out here. Thanks!

    Comment


    • #3
      Did they install on a system with the 'curl' package installed? As I mentioned curl depends on libcurl4 these days, which conflicts with libcurl3 which your package depends upon, according to apt/dpkg.

      I followed the instructions in the official documentation. And I use xtrabackup for mariadb primarily. All my systems are up to date Debian Stretch, for the most part, however I am also deploying new systems with Debian Buster, as that is the current stable version of Debian.

      Comment


      • #4
        Hi pridetechdesign!
        During the installation of percona-xtrabackup-24 on Debian Buster the following packages will be installed:
        libatomic1 libcurl4-openssl-dev libdbd-mysql-perl libdbi-perl libev4 libmariadb3 mariadb-common mysql-common percona-xtrabackup-24
        rsync
        Could you please show us the log of failed installation? Also from what repo you tried to install xtrabackup?
        Waiting for your reply.

        Comment


        • #5
          Tried again and this time it worked, I don't know what changed! Sorry to bother ya.

          Comment


          • #6
            Hey there thanks for letting us know, and no bother at all.
            Happens to me all the time... I like to put it down to static

            Comment

            Working...
            X