Emergency

Package does not match intended download Error.

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Package does not match intended download Error.

    Hi,

    Hoping someone here can help me out with a thorny issue.

    I'm trying to update Percona on our Centos 7 server

    sudo yum update percona-release

    but it fails with the error after running

    Total download size: 6.6 k
    Is this ok [y/d/N]: y
    Downloading packages:
    Delta RPMs disabled because /usr/bin/applydeltarpm not installed.
    percona-release-0.1-4.noarch.r FAILED 0% [ ] 0.0 B/s | 0 B --:--:-- ETA
    http://repo.percona.com/release/7/RP...-4.noarch.rpm: [Errno -1] Package does not match intended download. Suggestion: run yum --enablerepo=percona-release-noarch clean metadata
    Trying other mirror.


    Error downloading packages:
    percona-release-0.1-4.noarch: [Errno 256] No more mirrors to try.



    I've tried running

    yum --enablerepo=percona-release-noarch clean metadata

    and also

    yum clean all

    but they aren't resolving the issue.

    I've also tried downloading the RPM with WGET and running


    rpm --checksig percona-release-0.1-4.noarch.rpm

    which validates the rpm, which I think rules out any proxy isssues:


    percona-release-0.1-4.noarch.rpm: (sha1) dsa sha1 md5 gpg OK

    Can anyone help me shed any light on this?

    Many thanks in advance.

    James.


  • #2
    Hello, I have contacted our team and they suggest this would get you on your way:

    yum install http://www.percona.com/downloads/per...1-4.noarch.rpm

    See how you go?

    Comment


    • #3
      Thanks Lorraine, I'll give it a go and report back.

      James.

      Comment

      Working...
      X