Emergency

InnoDB: Operating system error number 24 in a file operation... again

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • InnoDB: Operating system error number 24 in a file operation... again

    Hi Guys.

    Seen this asked before many times and have followed advice and guidance but at a complete loss with this. I have followed the settings to the letter as set out at https://www.percona.com/blog/2016/12...number-tables/

    Running 'find /var/lib/mysql/ -name "*.ibd" | wc -l' returns 8338 so setting my limits of 2000000 seem really excessive.

    my.cnf (have **** out the wsrep_cluster_address, wsrep_sst_auth and wsrep_node_address)

    binlog_format = ROW
    innodb_buffer_pool_size = 2G
    innodb_flush_log_at_trx_commit = 0
    innodb_flush_method = O_DIRECT
    innodb_log_files_in_group = 2
    innodb_log_file_size = 20M
    innodb_file_per_table = 1
    transaction-isolation = READ-COMMITTED
    max_connections = 100

    wsrep_cluster_address = ********************
    wsrep_provider = /usr/lib64/libgalera_smm.so
    wsrep_sst_auth = ***********************
    wsrep_slave_threads = 8
    wsrep_cluster_name = pptdrupalcluster
    wsrep_node_address = *********************
    wsrep_node_name = Node2
    wsrep_sst_method = xtrabackup-v2
    default_storage_engine = InnoDB
    datadir = /var/lib/mysql
    open_files_limit = 2000000

    log_slave_updates
    innodb_locks_unsafe_for_binlog = 1
    innodb_autoinc_lock_mode = 2

    [mysqld_safe]
    pid-file = /run/mysqld/mysql.pid
    syslog


    My systems open file hard limit is set to 2000000 as well.

    Excerpt of /etc/security/limits.conf

    mysql hard nofile 2000000
    mysql soft nofile 2000000

    ulimit -a
    core file size (blocks, -c) 0
    data seg size (kbytes, -d) unlimited
    scheduling priority (-e) 0
    file size (blocks, -f) unlimited
    pending signals (-i) 31209
    max locked memory (kbytes, -l) 64
    max memory size (kbytes, -m) unlimited
    open files (-n) 1024
    pipe size (512 bytes, -p) 8
    POSIX message queues (bytes, -q) 819200
    real-time priority (-r) 0
    stack size (kbytes, -s) 8192
    cpu time (seconds, -t) unlimited
    max user processes (-u) 31209
    virtual memory (kbytes, -v) unlimited
    file locks (-x) unlimited

    Is there something else I'm missing with this?

    Thanks
    AST

  • #2
    This could be useful https://access.redhat.com/solutions/61334
    Did you restarted mysql service after changing open-files-limit parameter value in my.cnf ?

    Comment

    Working...
    X