pt-table-checksum doesn't hunt un-synced records

  • Filter
  • Time
  • Show
Clear All
new posts

  • pt-table-checksum doesn't hunt un-synced records


    I'm working on investigating a row in my slave replica which isn't synced with the master replica row. I'm using that slave for SELECT only.

    I ran pt-table-checksum on my master replica. It checked the table on master & slave both but it couldn't hunt the difference. I can clearly see the column records in the row on both instances and there is difference in many columns, only the first auto-increment column holds identical data else all columns differ.

    Is it because the pt-table-checksum works on the index not on the actuall row in table? I couldn't find any option in pt-table-checksum manual to force it to skip the index and actually checksum the row in table.

    When I do manually checksum the table in mysql I get a difference. Why pt-table-checksum failed in this situation and how can I make it work?

  • #2

    Can you provide commandline which you are running for checking checksum?


    • #3

      pt-table-checksum --user root --password myPassword --databases myDatabase --tables myTable --nocheck-replication-filters


      • #4

        You have to use a DSN to connect to your master.

        For example, if you want to check for the table staff inside the database sakila and the table user inside the database mysql, you will have to use something like:

        ./pt-table-checksum --tables=sakila.staff,mysql.user u=root,p=myPassword,h=masterhost

        If you want to check for "databases", you will have to use something like:

        ./pt-table-checksum --databases=sakila,mysql u=root,p=myPassword,S=/tmp/mysql_sandbox22183.sock,h=localho st

        You can't use the option --databases and --tables in the same check.

        Please check the documentation for more details. http://www.percona.com/doc/percona-toolkit/2.1/pt-table-chec ksum.html

        Martin Arrieta


        • #5
          hmm.. let me try