Buy Percona ServicesBuy Now!

Cannot start server after upgrading to 4.0

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Cannot start server after upgrading to 4.0

    I upgraded from 3.4 to 3.6 and to 4.0
    The upgrade to 3.6 secceded bu when upgrading to 4.0 it fails with the following error:

    I STORAGE [initandlisten] exception in initAndListen: 28574 Cannot start server. Detected data files in /var/lib/mongo created by storage engine 'wiredTiger'. The configured storage engine is 'mmapv1'., terminating

  • #2
    Hi danb@storenext it looks like a setting in your /etc/mongod.conf file got changed somehow when you upgraded to 4.0. The error is stating that the mongod process was expecting the storage engine to be MMAPv1, but it found data from the WiredTiger format in the directory. You can check things out by editing /etc/mongod.conf. Look for the key storage and underneath that you should see engine: MMAPv1 I would imagine. Go ahead and comment that line out (place a # at the beginning of the line) and then try restarting the mongod process.

    It could also be that you have the MMAPv1 data located at a different path than what the /etc/mongod.conf configuration is showing for your data path. You can find that in under the storage: header as dbPath. If this is the case, then change the path to the location of the MMAPv1 data files.

    Let us know if you have any other questions.

    ~Doug

    Comment

    Working...
    X