Buy Percona ServicesBuy Now!

PMM admin password no longer working

Collapse
This topic is closed.
X
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • PMM admin password no longer working

    I had our VMWare admin add two cores to the PMM server and after he rebooted it I can nolonger connect to graphana.

    The message I get is

    message "Invalid username or password"

    Sequence of events:
    1. The main web page gets displayed as expected and I am prompted for the admin pwd which works at this point.
    2. But when I click on Metrics Monitor the screen goes blank and I am told Invalid username or pwd


  • #2
    Hi baasp , sorry to hear you're being denied access. What version of PMM Server is this? Also how are you prompted for the password - is it the browser http basic auth popup box? Please attach a screenshot. Finally do you have ssh access to the Server? If this is in fact the nginx auth it can be updated in /etc/nginx/.htpasswd .

    I'll also escalate this for eyes from a Developer. Thanks,

    Comment


    • #3
      Thanks, I have uploaded the screenshots as requested.

      How do I reset the pwd in /etc/nginx/.htpasswd ?

      One other fact that may be very important is on restart of the server the nginx.service did not start. Check the screenshot pmm_serverstart please.
      Attached Files

      Comment


      • #4
        The output of systemctl status nginx.service


        [root@scordbapmm01 ~]# systemctl status nginx.service
        ● nginx.service - The nginx HTTP and reverse proxy server
        Loaded: loaded (/usr/lib/systemd/system/nginx.service; enabled; vendor preset: disabled)
        Active: active (running) since Tue 2018-03-13 15:07:32 UTC; 20h ago
        Process: 1403 ExecStart=/usr/sbin/nginx (code=exited, status=0/SUCCESS)
        Process: 1396 ExecStartPre=/usr/sbin/nginx -t (code=exited, status=0/SUCCESS)
        Process: 1395 ExecStartPre=/usr/bin/rm -f /run/nginx.pid (code=exited, status=0/SUCCESS)
        Main PID: 1405 (nginx)
        CGroup: /system.slice/nginx.service
        ├─1405 nginx: master process /usr/sbin/nginx
        ├─1406 nginx: worker process
        └─1407 nginx: worker process

        Mar 13 15:07:31 scordbapmm01.wco.int systemd[1]: Starting The nginx HTTP and reverse proxy server...
        Mar 13 15:07:31 scordbapmm01.wco.int nginx[1396]: nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/srv/nginx/certificate.crt"
        Mar 13 15:07:32 scordbapmm01.wco.int nginx[1396]: nginx: [warn] conflicting server name "_" on 0.0.0.0:80, ignored
        Mar 13 15:07:32 scordbapmm01.wco.int nginx[1396]: nginx: the configuration file /etc/nginx/nginx.conf syntax is ok
        Mar 13 15:07:32 scordbapmm01.wco.int nginx[1396]: nginx: configuration file /etc/nginx/nginx.conf test is successful
        Mar 13 15:07:32 scordbapmm01.wco.int nginx[1403]: nginx: [warn] "ssl_stapling" ignored, issuer certificate not found for certificate "/srv/nginx/certificate.crt"
        Mar 13 15:07:32 scordbapmm01.wco.int nginx[1403]: nginx: [warn] conflicting server name "_" on 0.0.0.0:80, ignored
        Mar 13 15:07:32 scordbapmm01.wco.int systemd[1]: Failed to read PID from file /run/nginx.pid: Invalid argument
        Mar 13 15:07:32 scordbapmm01.wco.int systemd[1]: Started The nginx HTTP and reverse proxy server.

        Comment


        • #5
          Good news. I reset the password for pmm in /etc/nginx/.htpasswd following

          https://www.digitalocean.com/communi...n-ubuntu-14-04

          I then rebooted and it all works now. Odd though as the admin pwd and the pmm pwd i setup are now different.

          Comment


          • #6
            Fantastic baasp , I'm glad to see this is solved for you!

            Comment

            Working...
            X