Buy Percona ServicesBuy Now!

Percona QAN wrong query abstract

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona QAN wrong query abstract

    Hello,

    In PMM version 1.5.3 I facing strange issue related to query abstract. It showing prefix with database name not existing on this server but exisiting on different server also connected to monitoring. Apart of that this information is also visible when I try to show table definition, status, indexes error is occuring that table doen't exist. Anyone focus similar issues?



  • #2
    Hi thanks for your report. We have encountered one other example of this and are actively working on it.
    Unfortunately, I can't share the bug details publically as it includes user-sensitive information.
    However, here is the bug link - once we create a reproducible test case then we'll be able to open it up for public view. https://jira.percona.com/browse/PMM-1745

    If you have new information or insight on your example, please feel free to share here.
    Please don't, though, post anything sensitive to this public forum. Thanks!.

    Comment


    • #3
      I have the same issues: database name doesn't match the query.

      Comment


      • #4
        What version are you using? I made some tests and problem for me is occurring with versions 1.4.0 - 1.5.3 . Version 1.3.2 work properly. One caveat is that in this version you need to manually add tables to see properties like indexes or table status. Maybe this problem is somehow related to this automatic process.

        Comment


        • #5
          I added PMM-1928 last week for this issue since I didnt find that bug report. What I additionally noticed is that the schema can differ between the summary and table section

          Comment

          Working...
          X