Buy Percona ServicesBuy Now!

Metric value doesn't show consistantly as 1 from mongodb_exporter

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Metric value doesn't show consistantly as 1 from mongodb_exporter

    Greetings
    Hopefully I am not missing something obvious but have been cracking at this with a couple of colleagues. We're hitting a sight problem with being able to see the balancer metrics in percona's mongodb_exporter. Love the detailed metrics just can't get this one rocking.

    Grafana promQL:max(mongodb_mongos_sharding_balancer_enable d{cluster="$cluster"})

    mongodb_mongos_sharding_balancer_enabled

    (cluster values are valid in the template) tried without max as well.

    Can't get the mongodb_mongos_sharding_balancer_enabled value to show as 1 (in PromQL or Grafana) or True although the balancer is always enabled. I see it showing as 1 occasionally but as I understand it should always be enabled and have a value of 1 or True. max(mongodb_mongos_sharding_balancer_enabled{clust er="$cluster"})

    The dashboard and value should always be 1. We're lookin at doing monitoring so the promql and accurate result would be key to be sure the alerts are ok.

    Our env
    RHEL 7.2
    Prometheus 2.0
    Percona mongodb_exporter
    mongodb_exporter, version 0.3.2 (branch: master, revision: adabd4fdd9b9a8835c2e57c327aa8d2dee9650be)
    build user: xxx_xxxxxx
    build date: 20171121-15:49:23
    go version: go1.8.3



  • #2
    Here is a Grafana screenshot if that helps.

    Comment

    Working...
    X