CentOS 6.3 & Percona 5.5.27

  • Filter
  • Time
  • Show
Clear All
new posts

  • CentOS 6.3 & Percona 5.5.27

    I apologize if this topic has been brought up but I could not find anything under search.

    I'm trying to compile Percona from source on my CentOS 6.3 32-bit VM. I run make and it goes up to 85% and stops with this error:

    /root/Percona-Server-5.5.27-rel28.0/sql/mysqld.cc: In function âvoid handle_connections_sockets()â:
    /root/Percona-Server-5.5.27-rel28.0/sql/mysqld.cc:5429: error: invalid conversion from âsize_socket*â to âsocklen_t*â
    /root/Percona-Server-5.5.27-rel28.0/sql/mysqld.cc:5429: error: initializing argument 3 of âint accept(int, sockaddr*, socklen_t*)â
    /root/Percona-Server-5.5.27-rel28.0/sql/mysqld.cc:5496: error: invalid conversion from âint*â to âsocklen_t*â
    /root/Percona-Server-5.5.27-rel28.0/sql/mysqld.cc:5496: error: initializing argument 3 of âint getsockname(int, sockaddr*, socklen_t*)â
    make[2]: *** [sql/CMakeFiles/sql.dir/mysqld.cc.o] Error 1
    make[1]: *** [sql/CMakeFiles/sql.dir/all] Error 2
    make: *** [all] Error 2

    Anyone have a clue what could be wrong?

  • #2
    Hi. I just tested this on Centos 6.3 32bit minimal and it compiled just fine. Prior to compiling Percona Server 5.5.27, I installed the following dependencies:
    yum install gcc gcc-c++ rpm-build cmake gperf ncurses-devel perl readline-dev time zlib-devel libaio-devel bison make

    I tried compiling from source and it compiled just fine:
    tar xzvf Percona-Server-5.5.27-rel28.0.tar.gz
    cd Percona-Server-5.5.27-rel28.0
    cmake .

    I tried compiling from rpmbuild and it compiled just fine too:
    rpm -Uvh Percona-Server-55-5.5.27-rel28.0.291.rhel6.src.rpm
    cd rpmbuild/SPECS
    rpmbuild -bb percona-server.spec

    Did you add additional parameters? Please let me know. Thanks!


    • #3
      I appreciate the response. I was using the standard Centos build. Using the minimal it compiled completely but with a lot of "warning: dereferencing type-punned pointer will break strict-aliasing rules" warnings. Compiling on a Debian system, these warnings don't show up.

      Using your steps I was able to get the MySQL server up and running but the warnings during compiling makes me a bit uneasy. Did you see any of those warnings?

      Thanks so much for your help.


      • #4
        A bug regarding this has been reported previously here https://bugs.launchpad.net/percona-server/+bug/1010950

        Let us know if you are seeing the same thing.

        Also, '-Wall -Werror' build won't work for various reasons (will post there in the bug).


        • #5
          Ah, looks like the same error. Thanks for the heads-up.