Percona on CENTOS 5.8

  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona on CENTOS 5.8

    Dear all,

    I install Percona 5.5 from yum command. And there is not any my.cnf by default, we known it.

    After install service mysql start normal.

    But when I add my customize my.cnf to /etc or /etc/mysql, service mysql doesn't start.

    This is the error:

    service mysql start [FAILED]
    Starting MySQL (Percona Server).The server quit without update PID file (/var/lib/mysql/c01.pid).

    This is my.cnf content:

    [mysqld]user = mysqldefault-storage-engine = InnoDBsocket = /var/lib/mysql/mysql.sock# pid_file = /var/lib/mysql/data/mysql.pidskip-name-resolvetransaction_isolation = READ-UNCOMMITTEDinnodb_buffer_pool_size = 800Minnodb_log_file_size = 200Minnodb_additional_mem_pool_size = 20Minnodb_file_per_table = 1innodb_log_buffer_size = 8Minnodb_flush_log_at_trx_commit = 1innodb_thread_concurrency = 4innodb_flush_method=O_DIRECTinnodb_read_io_thread s = 16innodb_write_io_threads = 16innodb_io_capacity=500innodb_lock_wait_timeout = 120innodb_data_file_path = ibdata1:100M;ibdata2:100M:autoextendlog_error = /var/log/mysqld/mysql-error.loglog_queries_not_using_indexes = 1slow_query_log = 1slow_query_log_file = /var/log/mysqld/slow.log

    Am I wrong when create my.cnf in /etc or /etc/mysql?


  • #2
    If delete my.cnf file, the service mysql start normally.

    I had turned off SELinux, but there's no change.

    How can I use my custom my.cnf?


    • #3
      What does the error log say ?


      • #4
        There is nothing in error log. The log I checked is from: /var/lib/mysql/c01.err (my linux name is: c01).

        I tried to delete the error log file before starting service with my custom /etc/my.cnf. But error log file was not created when starting service error.

        My percona server is fresh install on a fresh linux too. I tried on a VirtualBox, and this is a dedicated machine for percona, it runs percona only without any thing.


        • #5
          Interesting... I found something when I tried to write line by line of /etc/my.cnf. This is the result:

          1. Try with emply /etc/my.cnf: mysql start OK. That means nothing, but percona can load my.cnf normally.

          2. Some lines of configuration is the reason why percona can not start service. This is the last result of my.cnf file, if uncomment one of them, percona can not start:

          [mysql]port = 3306socket = /var/lib/mysql/mysql.sock[mysqld]user = mysqldefault-storage-engine = InnoDBsocket = /var/lib/mysql/mysql.sockskip-name-resolvetransaction_isolation = READ-UNCOMMITTEDinnodb_buffer_pool_size = 500M# 1. innodb_log_file_size = 10Minnodb_additional_mem_pool_size = 20Minnodb_file_per_table = 1innodb_log_buffer_size = 8Minnodb_flush_log_at_trx_commit = 1innodb_thread_concurrency = 4innodb_flush_method = O_DIRECTinnodb_read_io_threads = 8innodb_write_io_threads = 8innodb_io_capacity = 500innodb_lock_wait_timeout = 60# 2. innodb_data_file_path = ibdata1:20M:autoextendlog_error = /var/lib/mysql/error.loglog_queries_not_using_indexes = 1slow_query_log = 1slow_query_log_file = /var/log/mysql/slow.log

          Comment # 1. innodb_log_file_size = 10M

          Default value: innodb_log_file_size 5242880

          If I tried to double size: percona can not start.

          Comment # 2. innodb_data_file_path = ibdata1:20M:autoextend

          Default value: innodb_data_file_path = ibdata1:10M:autoextend

          Double size is OK. But when I tried to tripple size: percona can not start.

          Another things:

          1. log_error = /var/lib/mysql/error.log

          log_error can be only in /var/lib/mysql, if I tried to move to other place, eg: /var/log/mysql, percona can not start too.

          2. pid_file doesn't change when put pid_file=another value...

          Could you please to help me understand more about configuration and tuning percona server?


          • #6

            Most probably your mysql is failing because you change the size of the log file.

            You can check the error in /var/log/mysqld.log .

            Still try to delete ib_logfile0 and ib_logfile1 from /var/lib/mysql/ and then try to start mysql.