mysql_install_db fail with userstats ON

  • Filter
  • Time
  • Show
Clear All
new posts

  • mysql_install_db fail with userstats ON


    We're currently doing some installs with the latest 5.5 release (5.5.24 Rel26)

    We want to set specific directoires for datadir, innodb logs etc that are not the default, so prior to the rpm install we put our my.cnf in place.

    The RPM install works fine, but we seem to have no DB.

    I run mysql_install_db manually and it's failing consistently with the following in the error log:

    15:31:15 UTC - mysqld got signal 11 ;This could be because you hit a bug. It is also possible that this binaryor one of the libraries it was linked against is corrupt, improperly built,or misconfigured. This error can also be caused by malfunctioning hardware.We will try our best to scrape up some info that will hopefully helpdiagnose the problem, but since we have already crashed,something is definitely wrong and this may fail.key_buffer_size=8388608read_buffer_size=13107 2max_used_connections=0max_threads=400thread_count =1connection_count=0It is possible that mysqld could use up tokey_buffer_size + (read_buffer_size + sort_buffer_size)*max_threads = 881213 K bytes of memoryHope that's ok; if not, decrease some variables in the equation.Thread pointer: 0x19160250Attempting backtrace. You can use the following information to find outwhere mysqld died. If you see no messages after this, something wentterribly wrong...stack_bottom = 41099e98 thread_stack 0x40000/usr/sbin/mysqld(my_print_stacktrace+0x35)[0x7a4c35]/usr/sbin/mysqld(handle_fatal_signal+0x4a4)[0x67fcc4]/lib64/libpthread.so.0[0x2adfeb9fbbe0]/usr/sbin/mysqld[0x621ec6]/usr/sbin/mysqld(_Z24update_global_user_statsP3THDbl+0x3c2)[0x6239b2]/usr/sbin/mysqld(_Z11mysql_parseP3THDPcjP12Parser_state+0xaa )[0x589ffa]/usr/sbin/mysqld[0x58c3cd]/usr/sbin/mysqld(_Z19do_handle_bootstrapP3THD+0x16a)[0x58c6aa]/usr/sbin/mysqld(handle_bootstrap+0x51)[0x58c731]/lib64/libpthread.so.0[0x2adfeb9f377d]/lib64/libc.so.6(clone+0x6d)[0x2adfec7a625d]Trying to get some variables.Some pointers may be invalid and cause the dump to abort.Query (19173760): use mysqlConnection ID (thread ID): 1Status: NOT_KILLEDThe manual page at http://dev.mysql.com/doc/mysql/en/crashing.html containsinformation that should help you find out what is causing the crash.

    As soon as I remove userstats=ON from the my.cnf, it works fine, I can then put userstats=ON back into the my.cnf and I have no issues. Is this a known problem? Should I infact not be able to do this anyway?

    We are using puppet for pushing this out and this little hiccup means an additional manual step that we want to try and avoid.

  • #2
    I've tested with userstats=ON and it works (Same version).

    Could you please show us your my.cnf file and the output of "sh -x mysql_install_db"



    • #3
      Hmmmm Interesting...

      To clarify my steps...
      Puppet creates some subdirectories in /var/lib/mysql
      (data, iblogs, ibdata and binlogs)
      /etc/my.cnf put in place - referencing these directories such as datadir etc
      RPM's installed
      /var/liv/mysql/data contains empty mysql and test directories, error as reported was in the error log
      manual run of mysql_install_db also produced same errors.

      my.cnf as follows:

      ## This file is managed by puppet#[mysqld]socket=/var/lib/mysql/mysql.sockport=3306pid-file=/var/lib/mysql/mysqld.pid#skip-networking#log=/var/lib/mysql/logs/mysqld.genlog-error=/var/lib/mysql/logs/mysqld.errlog-warnings=1datadir=/var/lib/mysql/datawait_timeout=900interactive_timeout=900net_rea d_timeout=30#sort_buffer_size=1M#read_buffer_size= 128K#join_buffer_size=128Ksecure_auth=1slow_query_ logslow_query_log_file = /var/log/slowqueries/mysqld-slow.loglong_query_time = 5log-queries-not-using-indexesskip-name-resolvelocal-infile=0 # Disable LOAD DATA ***LOCAL*** INFILE# InnoDB Storage Engine Specific Settingsinnodb_data_file_path=ibdata1:10M:autoexte ndinnodb_data_home_dir=/var/lib/mysql/ibdatainnodb_log_group_home_dir=/var/lib/mysql/iblogsinnodb_buffer_pool_size=2Ginnodb_additional_ mem_pool_size=32Minnodb_flush_log_at_trx_commit=2i nnodb_log_buffer_size=8Minnodb_log_file_size=128Mi nnodb_support_xa=1innodb_flush_method=O_DIRECTinno db_file_per_table=1max_connections=400table_cache= 2048query_cache_size=400Mquery_cache_limit=4Mthrea d_cache_size=300myisam-recover=FORCE,BACKUPgroup_concat_max_len = 49152max_allowed_packet = 6291456# Percona Settingsuserstat = 1 [mysql]prompt = \D\n\u@dbmon.gs2.nap:\d>\_default-character-set = utf8

      As I was doing this, I noticed we have userstat though, and you say userstats - I'm wondering if this is a simple typo causing the issue!!

      Haven't sent output of mysql_install_db as requested as I already have the database running and in the middle of some other work, once complete I will trash and rebuild to repeat the error.


      • #4
        Sorry for my typo.. yes.. you are right and this looks like a bug when mysqld is running with the --bootstrap option.

        I'll recap the information and will create a bug for this issue later.



        • #5
          Great - Thanks for the updates!


          • #6
            This bug is reported in https://bugs.launchpad.net/percona-server/+bug/1008278

            Your workaround for now is to disable userstats and wait for the release of Percona Server 5.5.25 to enable it again.


            • #7
              Thanks for the update!

              Is there a date when 5.5.25 can be expected?


              • #8
                MySQL 5.5.25a has been released: http://www.mysqlperformanceblog.com/2012/07/21/announcing-pe rcona-server-5-5-25a-27-1/