Emergency

Unable to install percona server in Debian Stretch kernel 4.14.13-1

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to install percona server in Debian Stretch kernel 4.14.13-1

    Niltze [Hello]-

    Using Reieser4 OS on root file system successfully installed as seen in Installation Reports log:
    https://metztli.it/blog/index.php/am...reiser4-sfrn-4

    I have debian instances with lower kernel versions in the cloud with similar setup running MariaDB.

    Linux cipactli 4.14.0-3+reiser4.0.2-amd64 #1 SMP Debian 4.14.13-1+reiser4.0.2 (2018-01-15) x86_64 GNU/Linux
    cat /etc/os*
    PRETTY_NAME="Debian GNU/Linux 9 (stretch)"
    NAME="Debian GNU/Linux"
    VERSION_ID="9"
    VERSION="9 (stretch)"
    ID=debian
    HOME_URL="https://www.debian.org/"
    SUPPORT_URL="https://www.debian.org/support"
    BUG_REPORT_URL="https://bugs.debian.org/"

    I am just setting up a dedicated server for development. I have already installed from Debian repositories Apache2, PHP, etc.
    however, unable to install MariaDB 10.2 nor 10.3 I decided to try Percona especially since MariaDB server was unable to install and when forced, /var/log/syslog showed an error:

    Jan 14 06:25:39 cipactli mysqld_safe[11677]: 2018-01-14 6:25:39 140633683097792 [ERROR] InnoDB: Header page consists of zero bytes in datafile: ./ibdata1, Space ID:0, Flags: 0. Please refer to http://dev.mysql.com/doc/refman/5.7/...-datadict.html for how to resolve the issue.
    Jan 14 06:25:39 cipactli mysqld_safe[11677]: 2018-01-14 6:25:39 140633683097792 [ERROR] InnoDB: Corrupted page [page id: space=0, page number=0] of datafile './ibdata1' could not be found in the doublewrite buffer.
    Jan 14 06:25:39 cipactli mysqld_safe[11677]: 2018-01-14 6:25:39 140633683097792 [ERROR] InnoDB: Plugin initialization aborted with error Data structure corruption
    Jan 14 06:25:39 cipactli mysqld_safe[11677]: 2018-01-14 6:25:39 140633683097792 [Note] InnoDB: Starting shutdown...
    Jan 14 06:25:40 cipactli mysqld_safe[11677]: 2018-01-14 6:25:40 140633683097792 [ERROR] Plugin 'InnoDB' init function returned error.
    Jan 14 06:25:40 cipactli mysqld_safe[11677]: 2018-01-14 6:25:40 140633683097792 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.
    Jan 14 06:25:40 cipactli mysqld_safe[11677]: 2018-01-14 6:25:40 140633683097792 [Note] Plugin 'FEEDBACK' is disabled.
    Jan 14 06:25:40 cipactli mysqld_safe[11677]: ERROR: 1146 Table 'mysql.user' doesn't exist
    Jan 14 06:25:40 cipactli mysqld_safe[11677]: 2018-01-14 6:25:40 140633683097792 [ERROR] Aborting

    hence after downloading Percona bundle for AMD64:
    As root, this is the latest variation in my attempt to install Percona:

    I install one package first:

    $dpkg -i percona_01-16-2018/percona-server-common*deb
    Selecting previously unselected package percona-server-common-5.7.
    (Reading database ... 126712 files and directories currently installed.)
    Preparing to unpack .../percona-server-common-5.7_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking percona-server-common-5.7 (5.7.20-19-1.stretch) ...
    Setting up percona-server-common-5.7 (5.7.20-19-1.stretch) ...
    update-alternatives: warning: forcing reinstallation of alternative /etc/mysql/percona-server.cnf because link group my.cnf is broken

    Next this is order of list of the files I will install next:

    $ls percona_01-16-2018/lib*deb percona_01-16-2018/percona-server-client* percona_01-16-2018/percona-server-[rst]*deb
    percona_01-16-2018/libperconaserverclient20_5.7.20-19-1.stretch_amd64.deb
    percona_01-16-2018/percona-server-client-5.7_5.7.20-19-1.stretch_amd64.deb
    percona_01-16-2018/percona-server-rocksdb-5.7_5.7.20-19-1.stretch_amd64.deb
    percona_01-16-2018/percona-server-server-5.7_5.7.20-19-1.stretch_amd64.deb
    percona_01-16-2018/percona-server-tokudb-5.7_5.7.20-19-1.stretch_amd64.deb

    I install the files, subsequently:

    # dpkg -i percona_01-16-2018/lib*deb percona_01-16-2018/percona-server-client* percona_01-16-2018/percona-server-[rst]*deb
    Selecting previously unselected package libperconaserverclient20:amd64.
    (Reading database ... 126797 files and directories currently installed.)
    Preparing to unpack .../libperconaserverclient20_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking libperconaserverclient20:amd64 (5.7.20-19-1.stretch) ...
    Selecting previously unselected package percona-server-client-5.7.
    Preparing to unpack .../percona-server-client-5.7_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking percona-server-client-5.7 (5.7.20-19-1.stretch) ...
    Selecting previously unselected package percona-server-rocksdb-5.7.
    Preparing to unpack .../percona-server-rocksdb-5.7_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking percona-server-rocksdb-5.7 (5.7.20-19-1.stretch) ...
    Selecting previously unselected package percona-server-server-5.7.
    Preparing to unpack .../percona-server-server-5.7_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking percona-server-server-5.7 (5.7.20-19-1.stretch) ...
    Selecting previously unselected package percona-server-tokudb-5.7.
    Preparing to unpack .../percona-server-tokudb-5.7_5.7.20-19-1.stretch_amd64.deb ...
    Unpacking percona-server-tokudb-5.7 (5.7.20-19-1.stretch) ...
    Setting up libperconaserverclient20:amd64 (5.7.20-19-1.stretch) ...
    Setting up percona-server-client-5.7 (5.7.20-19-1.stretch) ...
    Setting up percona-server-server-5.7 (5.7.20-19-1.stretch) ...
    dpkg: error processing package percona-server-server-5.7 (--install):
    subprocess installed post-installation script returned error exit status 3 <====This is my issue.
    dpkg: dependency problems prevent configuration of percona-server-tokudb-5.7:
    percona-server-tokudb-5.7 depends on percona-server-server-5.7 (= 5.7.20-19-1.stretch); however:
    Package percona-server-server-5.7 is not configured yet.

    dpkg: error processing package percona-server-tokudb-5.7 (--install):
    dependency problems - leaving unconfigured
    dpkg: dependency problems prevent configuration of percona-server-rocksdb-5.7:
    percona-server-rocksdb-5.7 depends on percona-server-server-5.7 (= 5.7.20-19-1.stretch); however:
    Package percona-server-server-5.7 is not configured yet.

    dpkg: error processing package percona-server-rocksdb-5.7 (--install):
    dependency problems - leaving unconfigured
    Processing triggers for libc-bin (2.24-11+deb9u1) ...
    Processing triggers for man-db (2.7.6.1-2) ...
    Processing triggers for systemd (236-3~bpo9+1) ...
    Errors were encountered while processing:
    percona-server-server-5.7
    percona-server-tokudb-5.7
    percona-server-rocksdb-5.7

    Please note that upon forcing the server installation with dpkg --force-all -i percona-server-server-5.7*

    /var/log/syslog

    Jan 16 05:49:14 cipactli systemd[1]: Started User Manager for UID 109.
    Jan 16 05:49:14 cipactli mysql-systemd-start[5584]: 2018-01-16T13:49:14.399088Z 0 [Warning] 'NO_ZERO_DATE', 'NO_ZERO_IN_DATE' and 'ERROR_FOR_DIVISION_BY_ZERO' sql modes should be used with strict mode. They will be merged with strict mode in a future release.
    Jan 16 05:49:14 cipactli mysql-systemd-start[5584]: 2018-01-16T13:49:14.399141Z 0 [Warning] 'NO_AUTO_CREATE_USER' sql mode was not set.
    Jan 16 05:49:14 cipactli mysql-systemd-start[5584]: 2018-01-16T13:49:14.401752Z 0 [ERROR] --initialize specified but the data directory has files in it. Aborting.
    Jan 16 05:49:14 cipactli mysql-systemd-start[5584]: 2018-01-16T13:49:14.401884Z 0 [ERROR] Aborting

    Any feedback would be appreciated.
Working...
X