Emergency

Debian and dependencies

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • Debian and dependencies

    I have an debian 9.3 with added percona repo. Percona packages works fine, but i can't install some packages from main debian repo such as postfixadmin because default-mysql-client dependency required for it. This is meta package which installs MariaDB 10.1 client and apt suggest to remove percona server and percona client.

    Code:
    # apt install postfixadmin
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    The following packages were automatically installed and are no longer required:
    libmecab2 libnuma1 percona-server-common-5.7
    Use 'apt autoremove' to remove them.
    The following additional packages will be installed:
    dbconfig-common default-mysql-client dovecot-core galera-3 gawk libc-client2007e libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libexttextcat-2.0-0
    libexttextcat-data libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl
    libjemalloc1 liblwp-mediatypes-perl libstemmer0d liburi-perl mariadb-client-10.1 mariadb-client-core-10.1 mariadb-common mariadb-server mariadb-server-10.1
    mariadb-server-core-10.1 mlock php-imap php7.1-imap socat wwwconfig-common
    Suggested packages:
    dbconfig-mysql | dbconfig-pgsql | dbconfig-sqlite | dbconfig-sqlite3 | dbconfig-no-thanks ntp dovecot-gssapi dovecot-sieve dovecot-pgsql dovecot-mysql
    dovecot-sqlite dovecot-ldap dovecot-imapd dovecot-pop3d dovecot-lmtpd dovecot-managesieved dovecot-solr dovecot-lucene gawk-doc uw-mailutils
    libdata-dump-perl libipc-sharedcache-perl libwww-perl mailx mariadb-test netcat-openbsd tinyca mysql-client postgresql-client apache2
    Recommended packages:
    zendframework
    The following packages will be REMOVED:
    percona-server-client-5.7 percona-server-server-5.7
    The following NEW packages will be installed:
    dbconfig-common default-mysql-client dovecot-core galera-3 gawk libc-client2007e libcgi-fast-perl libcgi-pm-perl libencode-locale-perl libexttextcat-2.0-0
    libexttextcat-data libfcgi-perl libhtml-parser-perl libhtml-tagset-perl libhtml-template-perl libhttp-date-perl libhttp-message-perl libio-html-perl
    libjemalloc1 liblwp-mediatypes-perl libstemmer0d liburi-perl mariadb-client-10.1 mariadb-client-core-10.1 mariadb-common mariadb-server mariadb-server-10.1
    mariadb-server-core-10.1 mlock php-imap php7.1-imap postfixadmin socat wwwconfig-common
    0 upgraded, 34 newly installed, 2 to remove and 4 not upgraded.
    Need to get 30.0 MB of archives.
    After this operation, 16.9 MB disk space will be freed.
    How to find any way to fix this issue?

  • #2
    Hello thanks for this question..
    The team are taking a look and will hopefully we should be able to report back soon.

    Comment

    Working...
    X