Innodb - Error: trying to open a table

  • Filter
  • Time
  • Show
Clear All
new posts

  • Innodb - Error: trying to open a table


    every time MySQL is restarted, MySQL log shows errors of some temporary tables. I don't know if is a big issue.

    Extract of mysqld.log

    090616 11:26:02 InnoDB: Error: trying to open a table, but could notInnoDB: open the tablespace file './tmp/#sql2f89_6ee13_0.ibd'!InnoDB: Have you moved InnoDB .ibd files around without using theInnoDB: commands DISCARD TABLESPACE and IMPORT TABLESPACE?InnoDB: It is also possible that this is a temporary table #sql...,InnoDB: and MySQL removed the .ibd file for this.

    I have the same error for another two files:


    It's clear that is related with temporary tables of InnoDB. It's a bit annoying because every time I restart BD, the log is filled with same errors again.

    I ran mysqlcheck to test all tables of all databases and it seems to be ok. But the error is in log yet.

    Any suggestion?


  • #2
    1) What version of MySQL are you presently using?
    2) Did you create a temporary innodb table by any chance and mysql crashed before you could drop them?
    3) Do you find orphan #sql*.{frm,ibd} in your tmp directory?


    • #3
      Did You check cron (crontab, /etc/cron.*) for a cleaning script ?


      • #4
        Januzi: Just curious, how is this gonna help?


        • #5
          Mysql is complaining about missing files, so it could be possible that something removed them.


          • #6
            Could be, but I suspect thats unlikely the case. I was looking on the net and came across this bug report from mysql.
            http://bugs.mysql.com/bug.php?id=45443. You feel this is related?


            • #7
              1. MySQL version: 5.0.45-log
              3. Honestly, I don't know (
              3. Im pretty sure of found orphan #sql* on /tmp when issue happened. But my first action was remove them. I don't know if was a good choice, in fact, I don't know what is this kind of file. Is a temporary table manually created by a user?

              Actually BD is working well now but Im sure that if I restart BD the message will show again on log files. But it seems is not a big deal, isn't it?

              Thanks by your replies.


              • #8
                Ok. I posted a wrong bug report link earlier. This one is what I was hinting at. Did you go through a similar scenario like what is explained here?


                Doesn't seem like a big deal but its definitely an aberration to say the least. :roll: