Compiling Collectd against Percona 5.5.32 'mysql_get_server_version' not found

  • Filter
  • Time
  • Show
Clear All
new posts

  • Compiling Collectd against Percona 5.5.32 'mysql_get_server_version' not found

    Hello there,

    having a very frustrating issue trying to compile Collectd 5.4.0 with the MySQL plugin enabled, on Ubuntu Server 12.04. However, configure fails due to 'missing dependencies', namely 'libmysql . . . . . . no (symbol 'mysql_get_server_version' not found)'

    This seems to be an issue with the libmysqlclient library, which I got from the libmysqlclient-dev package on the Percona repo. I am explicitly linking to the library so I don't understand why this is.

    I believe this issue may be specific to Percona as opposed to just mySQL. On my dev machine, I was initially getting a error that libmysqlclient could not be found, so I installed the libmysqlclient-dev package. After that, configuration and compilation went fine and I was able to use Collectd away fine. However, when I tried to do the same setup on the production server, I ran into this issue. The only real difference I can think of that may matter is that on my dev machine I had originally installed vanilla MySQL and then switched to Percona Server, whereas the production machine was Percona from the very beginning.

    Any insight or suggestions would be very much appreciated.

    PS Another relevant bit of output from the configure script:
    checking mysql.h usability... yes
    checking mysql.h presence... yes
    checking for mysql.h... yes
    checking for mysql_init in -lmysqlclient... no
    checking for mysql_get_server_version in -lmysqlclient... no

  • #2
    Maximus, not sure if you were able to resolve this, but I was able to resolve this error on my system by installing MySQL-shared package in addition to the devel package. I am running the non percona version of mysql version 5.5.34.