Announcement

Announcement Module
Collapse
No announcement yet.

pt-table-checksum, replication filters

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • pt-table-checksum, replication filters

    Hi all,

    I'm getting an error with pt-table-checksum.


    Cannot checksum with --replicate because replication filters are set on these hosts:
    P=3306,S=/var/lib/mysql/mysql.sock,h=localhost,p=...,u=root
    replicate_ignore_table = prod_thr.semaphore
    P=3306,S=/var/lib/mysql/mysql.sock,h=pldnyi05.pgmedia.org,p= ...,u=root
    replicate_ignore_table = prod_thr.semaphore
    P=3306,S=/var/lib/mysql/mysql.sock,h=10.17.33.72,p=...,u=roo t
    replicate_ignore_table = prod_aw.semaphore
    Please read the --check-replication-filters documentation to learn how to solve this problem. at /usr/bin/pt-table-checksum line 5315.

    From the docs it is clear that this is caused by a replication filter. Yes I just added one for a SINGLE table, the drupal semaphore table. It's MyISAM and periodically (maybe once a month or so) we find replication dying due to this table. Since it doesn't need to replicate, we use a replicate_ignore_table option in our my.cnf file.

    Unfortunately it has broken our pt-table-checksum checks, which I *REALLY* want to have in place.

    How risky is this --nocheck-replication-filters flag? What exactly does it do?

    If the *ONLY* replication filter I have in place is this one rule to ignore the semaphore table, could that introduce serious problems? Obviously I don't want replication to break because of pt-table-checksum gathering on the master.

    Thoughts?

    Thx in advance!

    -Sean

  • #2
    The option is there to scare you into making sure you will be safe. We'd rather you are scared than that you blame us for breaking replication

    Without knowing exact details about your replication topology I can't give firm advice, but you shouldn't have any trouble knowing if this is unsafe. You should be able to pass the --ignore-tables option to the tool and then disable the check.

    Comment


    • #3
      Thx Baron. For the tool and the reply!

      I have no idea how you find the time to do all the stuff you do.

      PS: Just received your new book from Amazon. I'm 150 pages into it. Full of useful nuggets on every page. Will have a review of it posted soon enough.

      Cheers!
      -Sean

      Comment

      Working...
      X