GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

mk-table-checksum issue with mysql log tables

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • mk-table-checksum issue with mysql log tables

    Running the checksum script and it says that the general_log and slow_log files are different even though they are not used and contain no records.

    Any suggestions? I just ran "flush logs" maybe that will help.


    Differences on h=192.168.1.1
    DB TBL CHUNK CNT_DIFF CRC_DIFF BOUNDARIES
    mysql general_log 0 0 1 1=1
    mysql slow_log 0 0 1 1=1

    Differences on h=192.168.1.226
    DB TBL CHUNK CNT_DIFF CRC_DIFF BOUNDARIES
    mysql general_log 0 0 1 1=1
    mysql slow_log 0 0 1 1=1

  • #2
    I just realized that flush logs of course will not help with this issue. Specifically this issue is caused by the error generated with the mk-table-checksum process that I posted in a previous post:


    $VAR1 = {Code => '1592',Level => 'Note',Message => 'Statement may not be safe to log in statement format.'}; at /root/bin/mk-table-checksum line 5066. while doing mysql.general_log
    $VAR1 = {Code => '1592',Level => 'Note',Message => 'Statement may not be safe to log in statement format.'}; at /root/bin/mk-table-checksum line 5066. while doing mysql.slow_log

    These errors refer to the general_log and slow_log tables and these are the tables that are showing not synched up.

    So now the question is really what is causing this error...

    Comment


    • #3
      This article seems to be very related?

      http://bugs.mysql.com/bug.php?id=42851

      Comment


      • #4
        Its fun replying to myself ). Alas, hopefully someone will find this useful.

        My understanding is that these tables are essentially independent on each system, so testing replication on them is unnecessary. I initially prevented replication from checking these tables by using the --table-ignore option and then switched to the --ignore-databases option and am now only checksumming the databases that I care about.

        Comment

        Working...
        X