Announcement

Announcement Module
Collapse
No announcement yet.

sysbench duplicate entries

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • sysbench duplicate entries

    I am running sysbench on a 3 node galera cluster with a DB that has 500M rows.

    When running the benchmark I get a lot of "Err1062 Duplicate entry" errors that forces sysbench to exit.

    I read somewhere that there is an option --mysql-ignore-duplicates=on that would fix this, but sysbench 0.4.12 on ubuntu oneiric does appear to support such an option.

    My sysbench command line is as follows:

    sysbench --test=oltp --db-driver=mysql --mysql-engine-trx=yes --mysql-table-engine=innodb --mysql-user=XXX--mysql-password=XXX --num-threads=256 --max-requests=73000 --oltp-table-size=500000000 --mysql-host=XXX --mysql-port=3307 --oltp-test-mode=complex --oltp-auto-inc=off --oltp-dist-type=uniform run

    Is there anyway I can use sysbench on galera cluster without getting these errors?
    I get these errors consistently and more and more as the time goes on. This makes using sysbench impossible.

  • #2
    meant to say sysbench does "not" support the option --mysql-ignore-duplicates

    Comment


    • #3
      hi,
      i have a similar problem.
      i have a 3 nodes galera cluster. sysbench 0.4.12 on debian.

      Prepare bench:
      sysbench --db-driver=mysql --num-threads=32 --max-time=300 --max-requests=500000 --mysql-user=appuser --mysql-host=10.xx.xx.xx --mysql-port=33306 --mysql-password='xxxxxxxxx' --oltp-auto-inc=off --test=oltp --oltp-test-mode=complex --oltp-table-size=5000000 --mysql-table-engine=innodb prepare

      Run bench:
      sysbench --db-driver=mysql --num-threads=32 --max-time=300 --max-requests=500000 --mysql-user=appuser --mysql-host=10.xx.xx.xx --mysql-port=33306 --mysql-password='xxxxxxxxx' --oltp-auto-inc=off --test=oltp --oltp-test-mode=complex --oltp-table-size=5000000 --mysql-table-engine=innodb run

      error messages:
      ALERT: failed to execute mysql_stmt_execute(): Err1317 Query execution was interrupted
      or
      ALERT: failed to execute mysql_stmt_execute(): Err1062 Duplicate entry '2481816' for key 'PRIMARY'


      the option "mysql-ignore-duplicates" is unkown

      thank for your help.

      Comment


      • #4
        hi,
        i resolved my problem by installing sysbench 0.5

        sysbench --db-driver=mysql --num-threads=16 --max-time=300 --max-requests=500000 --mysql-user=appuser --mysql-host=10.xx.xx.xx --mysql-port=33306 --mysql-password='password' --oltp-auto-inc=off --test=/home/test/sysbench/sysbench/tests/db/oltp.lua --oltp-test-mode=complex --oltp-table-size=5000000 --mysql-table-engine=innodb run

        Comment

        Working...
        X