Announcement

Announcement Module
Collapse
No announcement yet.

IST fails when joining slaves back to cluster

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • IST fails when joining slaves back to cluster

    Hi!

    We are building master/slave setup for website that required autoincrementals to be +1 (thats the main reason for master/slave and not putting up multimaster).

    Thus far we have been successful in getting our cluster up and running but after our slave server was rebooted we noticed that they can't join back in to the cluster without doing full SST transfer first.

    I think there is something wrong with our grastate.dat files.

    This is from one of our joined slaves after full SST and left running for few hours:


    # GALERA saved stateversion: 2.1uuid: c369e192-4818-11e2-0800-7697bb058ff4seqno: -1cert_index:


    I did notice that the seqno is set to -1, then I checked it up from our Master and seqno was -1 there too. Is this the reason why IST fails and if so, how to fix it?

    Settings from master1 related to wsrep: (wsrep_provider_options is in 1 row)


    wsrep_provider = /usr/lib64/libgalera_smm.sowsrep_cluster_address = gcomm://slave1IpHere,slave2IpHere,slave3IpHerewsrep_provid er_options = 'gcache.size=4G; gcs.fc_limit = 256; gcs.fc_factor=0.9; gcs.fc_master_slave = yes; pc.bootstrap=1'wsrep_auto_increment_control = 0 # This is disabled so that autoinc is 1wsrep_slave_threads = 24wsrep_cluster_name = ourClusterwsrep_sst_method = xtrabackupwsrep_sst_auth = SstUserHere:SstPwdHerewsrep_node_name = master1wsrep_node_address = master1IpHerewsrep_causal_reads = ON


    And settings from slave1 about wsrep: (wsrep_provider_options is in 1 row)


    wsrep_provider = /usr/lib64/libgalera_smm.sowsrep_cluster_address = gcomm://master1IpHere?pc.wait_prim=yeswsrep_provider_optio ns = 'gcache.size=4G; gcs.fc_limit = 256; gcs.fc_factor=0.9; gcs.fc_master_slave = yes; evs.keepalive_period = PT3S; evs.inactive_check_period = PT10S; evs.suspect_timeout = PT30S; evs.inactive_timeout = PT1M; evs.install_timeout = PT1M'wsrep_sst_auth = SstUserHere:SstPwdHerewsrep_auto_increment_control = 0 # This is disabled so that autoinc is 1wsrep_slave_threads = 24wsrep_cluster_name = ourClusterwsrep_sst_method = xtrabackupwsrep_node_name = slave1wsrep_node_address = slave1IpHerewsrep_causal_reads = ON


    List of installed Percona software, all servers are running 64bit CentOS 6.3:
    Percona-XtraDB-Cluster-client.x86_64 1:5.5.28-23.7.369.rhel6 @percona
    Percona-XtraDB-Cluster-galera.x86_64 2.0-1.117.rhel6 @percona
    Percona-XtraDB-Cluster-server.x86_64 1:5.5.28-23.7.369.rhel6 @percona
    Percona-XtraDB-Cluster-shared.x86_64 1:5.5.28-23.7.369.rhel6 @percona
    percona-release.x86_64 0.0-1 installed
    percona-xtrabackup.x86_64 2.0.4-484.rhel6 @percona
Working...
X