GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

wsrep_cluster_size=1 & wsrep_ready=ON. What is wrong?

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • wsrep_cluster_size=1 & wsrep_ready=ON. What is wrong?

    Hi:

    First, sorry for my english, i know isn't very good, but i hope that you can understand it.

    Im new with XtraDB Cluster and im testing it.

    I've mounted a 3 nodes XtraDB Cluster, and all seems to work ok. Now i'm testing to defeat nodes and i've some issues.
    I turned off 2 nodes, and let only one on. I suposed that the node will don't work but it's still working ok.

    wsrep_cluster_size=1 and wsrep_ready=ON, and clustercheck returns that the Percona XtraDB Cluster Node is synced. You can see the attached file.

    I'm able to use the mysql server and work with the data and not receive any message of error like:
    ERROR 1213 (40001): Deadlock found when trying to get lock; try restarting transaction
    ERROR 1047 (08S01): Unknown command

    The part of my.cnf of the 3 nodes relative to the cluster is:

    [mysqld_safe]
    wsrep_urls= gcomm://10.253.5.135:4567,gcomm://10.253.5.136:4567,gcomm:// 10.253.5.137:4567

    [mysqld]
    #wsrep_cluster_address=gcomm://10.253.5.135
    wsrep_provider=/usr/lib64/libgalera_smm.so

    wsrep_slave_threads=4
    wsrep_cluster_name=mysqlcs01
    wsrep_sst_method=xtrabackup
    wsrep_node_name=mysqlnd02
    wsrep_sst_auth=xtrabackupuser:xtrabackuppass

    log_slave_updates

    innodb_locks_unsafe_for_binlog=1
    innodb_autoinc_lock_mode=2


    What is wrong with my cluster?

    Thanks.
Working...
X