Announcement

Announcement Module
Collapse
No announcement yet.

Where can I download Percona-XtraDB-Cluster-galera.i686?

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Where can I download Percona-XtraDB-Cluster-galera.i686?

    This list doesn't include: http://www.percona.com/downloads/Percona-XtraDB-Cluster/5.5. 27-23.6/RPM/rhel5/i686/

    Belows is the error when installing Percona-XtraDB-Cluster-server:

    1:Percona-XtraDB-Cluster-server-5.5.27-23.6.356.rhel5.i686 from percona has depsolving problems --> Missing Dependency: Percona-XtraDB-Cluster-galera is needed by package 1:Percona-XtraDB-Cluster-server-5.5.27-23.6.356.rhel5.i686 (percona)Error: Missing Dependency: Percona-XtraDB-Cluster-galera is needed by package 1:Percona-XtraDB-Cluster-server-5.5.27-23.6.356.rhel5.i686 (percona) You could try using --skip-broken to work around the problem You could try running: package-cleanup --problems package-cleanup --dupes rpm -Va --nofiles --nodigest


    Where can I download it? Must I compile from source or convert from .deb?

  • #2
    Hi,

    Percona-XtraDB-Cluster-galera" is listed in 64-bit versions ( http://www.percona.com/downloads/Percona-XtraDB-Cluster/5.5. 27-23.6/RPM/rhel5/x86_64/) but not in 32-bit ( http://www.percona.com/downloads/Percona-XtraDB-Cluster/5.5. 27-23.6/RPM/rhel5/i686/). I will check with the build engineer and inform you with his reply.

    You can also try to install xtradb cluster through repositories.

    http://www.percona.com/doc/percona-xtradb-cluster/installati on.html#using-percona-software-repositories

    Comment


    • #3
      Hi,

      Can you please check again? Galera packages are included now in below list. Thanks.

      http://www.percona.com/downloads/Percona-XtraDB-Cluster/5.5. 27-23.6/RPM/rhel5/i686/

      Comment


      • #4
        I solved this by installing galera and compiling xtradb cluster from source as mentioned here.

        niljoshi wrote on Wed, 12 September 2012 20:59
        Hi,

        Can you please check again? Galera packages are included now in below list. Thanks.

        http://www.percona.com/downloads/Percona-XtraDB-Cluster/5.5. 27-23.6/RPM/rhel5/i686/
        But it still is not available in the repo (after running `yum clean all`):


        # yum search galeraLoaded plugins: downloadonly, fastestmirrorLoading mirror speeds from cached hostfile * atomic: mir01.syntis.net * base: centos.ustc.edu.cn * epel: mirrors.ustc.edu.cn * extras: mirrors.grandcloud.cn * jpackage-generic: sunsite.rediris.es * rpmforge: nl.mirror.eurid.eu * updates: mirrors.grandcloud.cnWarning: No matches found for: galeraNo Matches found


        I installed it from the above list, then install xtradb cluster but get the following errors:


        ================================================== ================================================== ========================= Package Arch Version Repository Size============================================== ================================================== =============================Installing: Percona-XtraDB-Cluster-server i686 1:5.5.27-23.6.356.rhel5 percona 20 MInstalling for dependencies: Percona-SQL-client-50 i686 5.0.92-b23.88.rhel5 percona 361 k Percona-SQL-shared-50 i686 5.0.92-b23.88.rhel5 percona 1.8 M Percona-XtraDB-Cluster-shared i686 1:5.5.27-23.6.356.rhel5 percona 967 k percona-xtrabackup i386 2.0.2-461.rhel5 percona 4.4 MTransaction Summary=========================================== ================================================== ================================Install 5 Package(s)Upgrade 0 Package(s)Total size: 27 MIs this ok [y/N]: yDownloading Packages:Running rpm_check_debugRunning Transaction TestFinished Transaction TestTransaction Check Error: file /usr/lib/libmysqlclient.so conflicts between attempted installs of Percona-XtraDB-Cluster-shared-5.5.27-23.6.356.rhel5.i686 and Percona-SQL-shared-50-5.0.92-b23.88.rhel5.i686 file /usr/lib/libmysqlclient_r.so conflicts between attempted installs of Percona-XtraDB-Cluster-shared-5.5.27-23.6.356.rhel5.i686 and Percona-SQL-shared-50-5.0.92-b23.88.rhel5.i686Error Summary-------------


        thus I must remove the Percona-SQL-shared first:


        rpm -e --nodeps Percona-SQL-shared-50-5.0.92-b23.88.rhel5


        and then it is installed successfully.

        You should check the dependencies again, on x86_64, it only pulls Percona-XtraDB-Cluster-shared, not both: Percona-XtraDB-Cluster-shared and Percona-SQL-shared.

        Comment

        Working...
        X