GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

XtraDB Cluster wont start with wsrep_provider

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • XtraDB Cluster wont start with wsrep_provider

    hi,
    i tried to install the percona cluster on a fresh debian and even ubuntu system, but every time i'm ready with the installation and config the mysql wont start anymore. the problem is the line with the wsrep_provider (wsrep_provider=/usr/lib/libgalera_smm.so). when i remove the line the server starts without any problems.

    is there anything i have overlooked?

    syslog with wsrep_provider:
    Aug 10 17:42:01 net1 /etc/init.d/mysql[10691]: 0 processes alive and '/usr/bin/mysqladmin --defaults-file=/etc/mysql/debian.cnf ping' resulted in
    Aug 10 17:42:01 net1 /etc/init.d/mysql[10691]: #007/usr/bin/mysqladmin: connect to server at 'localhost' failed
    Aug 10 17:42:01 net1 /etc/init.d/mysql[10691]: error: 'Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)'
    Aug 10 17:42:01 net1 /etc/init.d/mysql[10691]: Check that mysqld is running and that the socket: '/var/run/mysqld/mysqld.sock' exists!
    Aug 10 17:42:01 net1 /etc/init.d/mysql[10691]:

    syslog wsrep_provider removed:
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9622]: Upgrading MySQL tables if necessary.
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9626]: /usr/bin/mysql_upgrade: the '--basedir' option is always ignored
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9626]: Looking for 'mysql' as: /usr/bin/mysql
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9626]: Looking for 'mysqlcheck' as: /usr/bin/mysqlcheck
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9626]: This installation of MySQL is already upgraded to 5.5.24, use --force if you still need to run mysql_upgrade
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9637]: Checking for insecure root accounts.
    Aug 10 17:41:32 net1 /etc/mysql/debian-start[9642]: Triggering myisam-recover for all MyISAM tables

    mysqld config
    [mysqld]

    wsrep_provider=/usr/lib/libgalera_smm.so
    wsrep_cluster_address=gcomm://10.10.10.21

    wsrep_slave_threads=8
    wsrep_sst_method=rsync

    wsrep_cluster_name=db_cluster
    wsrep_node_name=net1

    binlog_format=ROW
    default_storage_engine=InnoDB
    innodb_autoinc_lock_mode=2
    innodb_locks_unsafe_for_binlog=1

  • #2
    Hi chriss,

    do you have the file /usr/lib/libgalera_smm.so present on your system in that directory ?

    if the file is present, could you paste the start of the log too ?

    Regards,

    Comment

    Working...
    X