GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Percona XTraDB Cluster Server not starting

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona XTraDB Cluster Server not starting

    Hi,

    I am trying to start Percona XtraDB Cluster server after following the documentation. The Server is installed on Ubunto 12.04

    I get this error when I run mysqld :

    120730 18:25:55 [Note] WSREP: Read nil XID from storage engines, skipping position init
    120730 18:25:55 [Note] WSREP: wsrep_load(): loading provider library '/rcloud/Percona-XtraDB-Cluster-5.5.24-23.6.342.Linux.x86_64 /lib/libgalera_smm.so'
    120730 18:25:55 [ERROR] WSREP: wsrep_load(): dlopen(): libssl.so.10: cannot open shared object file: No such file or directory
    120730 18:25:55 [ERROR] WSREP: wsrep_load(/rcloud/Percona-XtraDB-Cluster-5.5.24-23.6.342.Li nux.x86_64/lib/libgalera_smm.so) failed: Invalid argument (22). Reverting to no provider.
    120730 18:25:55 [Note] WSREP: Read nil XID from storage engines, skipping position init
    120730 18:25:55 [Note] WSREP: wsrep_load(): loading provider library 'none'
    120730 18:25:55 [ERROR] Aborting

    the my.4000.cnf file I use to start is as given below:

    ============================
    [mysqld]
    gdb

    datadir=/rcloud/percona_cluster/data/d1
    basedir=/rcloud/Percona-XtraDB-Cluster-5.5.24-23.6.342.Linux .x86_64

    port = 4000
    socket=/tmp/mysql.4000.sock

    user=root

    binlog_format=ROW

    wsrep_provider=/rcloud/Percona-XtraDB-Cluster-5.5.24-23.6.34 2.Linux.x86_64/lib/libgalera_smm.so

    wsrep_cluster_address=gcomm://

    wsrep_provider_options = "gmcast.listen_addr=tcp://0.0.0.0:4010; "
    wsrep_sst_receive_address=192.168.0.12:4020

    wsrep_slave_threads=2
    wsrep_cluster_name=trimethylxanthine
    wsrep_sst_method=rsync
    wsrep_node_name=node4000

    innodb_locks_unsafe_for_binlog=1
    innodb_autoinc_lock_mode=2

    ============================

    Have anyone come across this error? Any idea how this can be reolved?

  • #2
    Hi,

    I guess, the issue is with this line.
    "120730 18:25:55 [ERROR] WSREP: wsrep_load(): dlopen(): libssl.so.10: cannot open shared object file: No such file or directory"

    Can you check with the command "dpkg -L libssl1.0.0" that libssl.so file is there or not? If not than can you install "libssl1.0.0" with apt-get install libssl1.0.0 command and check?

    Comment


    • #3
      Thanks. The libssl was already installed. I could get it working after cleaning up the default mysql instance and then installed the Percona Server from apt-get, pointed out to the Galera lib in /user/lib. Now running perfectly well.

      Thanks
      Dhanush

      Comment

      Working...
      X