GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

xtrabackup method does not honor user=mysql in my.cnf

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup method does not honor user=mysql in my.cnf

    I have setup a Percona XtraDB Cluster Percona-XtraDB-Cluster-server 5.5.24-23.6.340.rhel6 (CentOS 6.3 AWS EC2) on two nodes (will change to 3 when everything works properly). Here is my.cnf on the first node:

    [mysqld]datadir=/data/mysql-datauser=mysqlserver_id=1binlog_format=ROWwsrep_pr ovider=/usr/lib64/libgalera_smm.sowsrep_cluster_address=gcomm://wsrep_slave_threads=2wsrep_cluster_name=a-clusterwsrep_sst_method=xtrabackupwsrep_node_name= db-prod-1innodb_locks_unsafe_for_binlog=1innodb_autoinc_lo ck_mode=2innodb_buffer_pool_size=400Minnodb_log_fi le_size=64M

    The configuration worked fine when I set wsrep_sst_method to rsync on both nodes, but when I change to xtrabackup, I could start the first node but failed with the second node. I check the innobackupex.backup.log file on the first node and see this:

    120727 09:59:23 innobackupex: Starting mysql with options: --unbuffered --120727 09:59:23 innobackupex: Connected to database with mysql child process (pid=10606)innobackupex: Error: mysql child process has died: ERROR 1045 (28000): Access denied for user 'ec2-user'@'localhost' (using password: NO)

    Why innobackupex use 'ec2-user' (this is one of the system user, this user is in the sudoer list, and start the mysql with the command 'sudo service mysql start') instead of 'mysql' (configured in my.cnf)? Is it a bug?
    Btw, I did not see any documentation on how to specify the password for the user used by xtrabackup to connect with mysql for backup.


    Any hint would be appreciated.
    Thanks.

  • #2
    Anyone?

    Comment


    • #3
      Hi,

      You need to provide to the SST script (in this case xtrabackup) the credentials.

      You can do this by adding in my.cnf ([mysqld] section) the following:

      wsrep_sst_auth=rootassword


      Regards,

      Comment

      Working...
      X