GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Error when using the 'check' option in Haproxy

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error when using the 'check' option in Haproxy

    Hello! I am installing Percona XtraDB Cluster as described in the documentation. However, if I set the Haproxy's 'check' option I get an error: "Mysql2 :: Error: Lost connection to MySQL server at 'reading initial communication packet', system error: 0". If this option is not specified, then it works. But in this case I can not configure failover. Thanks in advance for your help. I attach the configuration files (and sorry for my English):
    -------------------------------------------------------

    #my haproxy.cfg file:
    global
    log 127.0.0.1 local0
    log 127.0.0.1 local1 notice
    maxconn 4096
    uid 99
    gid 99
    daemon
    #debug
    #quiet

    defaults
    log global
    mode http
    option tcplog
    option dontlognull
    retries 3
    option redispatch
    maxconn 2000
    contimeout 5000
    clitimeout 50000
    srvtimeout 50000

    listen pxdb-cluster 192.168.0.71:3305
    mode tcp
    balance roundrobin
    option mysql-check user mysqlcheck
    server node1 192.168.0.71:3306 check

    ----------------------------------------
    #my my.cnf file:
    [mysqld]

    binlog_format=ROW
    wsrep_cluster_address=gcomm://
    wsrep_provider=/usr/lib/libgalera_smm.so

    wsrep_slave_threads=2
    wsrep_cluster_name=pxc_test
    wsrep_sst_method=rsync
    wsrep_node_name=node1

    innodb_locks_unsafe_for_binlog=1
    innodb_autoinc_lock_mode=2

    ----------------------------------------
    I use xubuntu 12.04, haproxy 1.4, PerconaXDC 5.5

  • #2
    I understand. I forgot to add the mysqlcheck user to the database. Now it works. Maybe this will help someone.

    Comment

    Working...
    X