GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Percona Xtradb Cluster Dependencies

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Percona Xtradb Cluster Dependencies

    Hello.

    I'd like to start by apologizing if this topic was already discussed, but I couldn't find any references and I am new to this forum.


    I'm trying to create a live-build of Debian 7 which I'm going to use in a system which is part of a Percona Cluster. Until last week, all I had to do was
    to include percona-xtradb-cluster-client-5.5 and percona-xtradb-cluster-server-5.5 in the list of binaries that live-build has to install. And it worked fine.
    This week, I get the following error, for both binaries:
    "percona-xtradb-cluster-client-5.5: Dependencies, percona-xtradb-cluster-common-5.5"
    and live-build cannot successfully generate the live image.

    If I add percona-xtradb-cluster-common-5.5 to list given to live build, it logs the error "percona-xtradb-cluster-common-5.5: Conflicts: mysql-common".

    I know I could install Percona cluster after generating the live image, but I would prefer if I didn't have to.

    Thx,

  • #2
    Hi,

    Why don't you use Percona apt repo and apt-cache to see what are the dependencies needed for installing percona-xtradb-cluster-server-5.5? Like:
    Code:
    root@debian-7:~# apt-cache show percona-xtradb-cluster-server-5.5
    Package: percona-xtradb-cluster-server-5.5
    Source: percona-xtradb-cluster-5.5
    Version: 5.5.37-25.10-756.wheezy
    Architecture: amd64
    Maintainer: Percona Server Development Team <mysql-dev@percona.com>
    Installed-Size: 216957
    Pre-Depends: percona-xtradb-cluster-common-5.5 (>= 5.5.37-25.10-756.wheezy), adduser (>= 3.4.0), debconf
    Depends: percona-xtradb-cluster-client-5.5 (>= 5.5.37-25.10-756.wheezy), libdbi-perl, libdbd-mysql-perl, perl (>= 5.6), libaio1 (>= 0.3.93), libc6 (>= 2.12), libgcc1 (>= 1:4.1.1), libpam0g (>= 0.99.7.1), libssl1.0.0 (>= 1.0.0), libstdc++6 (>= 4.6), libwrap0 (>= 7.6-4~), zlib1g (>= 1:1.2.0), debconf (>= 0.5) | debconf-2.0, psmisc, passwd, lsb-base (>= 3.0-10), percona-xtradb-cluster-galera-25, percona-xtrabackup (>= 2.1.6), socat, lsof, rsync, iproute
    However, for me the latest version of percona-xtradb-cluster-common-5.5 does not conflict with mysql-common, I can install both using apt:
    Code:
    ii  mysql-common                       5.5.37-0+wheezy1              all          MySQL database common files, e.g. /etc/mysql/my.cnf
    ii  percona-xtradb-cluster-common-5.5  5.5.37-25.10-756.wheezy       all          Percona XtraDB Cluster database common files (e.g. /etc/mysql/my.cnf)
    What were the version you used?

    Comment


    • #3
      Thanks for the reply. I will try to follow all the advices. I cannot use apt for installing because I'm using live build to build a live ISO of Debian 7. Of course I could generate the ISO and then after the first boot to install mysql Server but I would like to avoid that.

      Thanks again.

      Comment

      Working...
      X