GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Flow Control

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Flow Control

    I have a question about the relationship between the status variables wsrep_flow_control_paused and wsrep_flow_control_sent.

    I have a three-node PXC 5.6 cluster (Galera 3.3 (r171)) and I am seeing numbers in the hundreds of ms for wsrep_flow_control_paused, but wsrep_flow_control_sent is always zero. What would be causing the values for wsrep_flow_control_paused if there are no flow control events?

    Here is some sample output from myq_gadgets 'wsrep'. The values for the other two nodes are essentially the same for p_ms and snt. All of the values for p_ms (wsrep_flow_control_sent) are zero on all three nodes. gcs.fc_limit is set to the default 16 so the queue on this node is exceeding the limit occasionally.

    Wsrep Cluster Node Queue Ops Bytes Flow Conflct PApply Commit
    time P cnf # cmt sta Up Dn Up Dn Up Dn p_ms snt lcf bfa dst oooe oool wind
    09:42:33 P 85 3 Sync T/T 0 29 0 5k 0 2.0M 1k 0 0 0 1 2 0 1
    09:42:38 P 85 3 Sync T/T 0 7 0 5k 0 2.0M 2k 0 0 0 1 2 0 1
    09:42:44 P 85 3 Sync T/T 0 0 0 3k 0 1.5M 426 0 0 0 1 2 0 1
    09:42:49 P 85 3 Sync T/T 0 2 0 3k 0 1.4M 648 0 0 0 1 2 0 1
    09:42:55 P 85 3 Sync T/T 0 0 0 3k 0 1.2M 570 0 0 0 1 2 0 1
    09:43:00 P 85 3 Sync T/T 0 2 0 4k 0 1.8M 1k 0 0 0 1 2 0 1
    09:43:06 P 85 3 Sync T/T 0 6 0 3k 0 1.3M 2k 0 0 0 1 2 0 1
    09:43:11 P 85 3 Sync T/T 0 28 0 5k 0 2.0M 1k 0 0 0 1 2 0 1
    09:43:17 P 85 3 Sync T/T 0 0 0 5k 0 2.0M 1k 0 0 0 1 2 0 1
    09:43:22 P 85 3 Sync T/T 0 1 0 5k 0 2.1M 968 0 0 0 1 2 0 1
    09:43:28 P 85 3 Sync T/T 0 3 0 5k 0 1.9M 226 0 0 0 1 2 0 1

  • #2
    Correction. Where I said "the values for p_ms (wsrep_flow_control_sent)", I meant "the values for snt (wsrep_flow_control_sent)".

    Comment


    • #3
      Apparently the problem was a bug in myq_status. I downloaded the latest version from GitHub and I am now getting values for "snt".

      Comment

      Working...
      X