Announcement

Announcement Module
Collapse
No announcement yet.

garbd gu::NotSet error

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • garbd gu::NotSet error

    I'm using Ubuntu 12.04 LTS x64 and installed the latest garbd package:

    percona-xtradb-cluster-garbd-3.x 207.precise

    However, I can't figure out how to get it working. I've tried the command "garbd -a gcomm://192.168.128.203 -g mycluster" which results in the gu::NotSet error.

    I read in lp someone suggested the -o gmcast.listen parameter below (I assume to use the ip address of the node running garbd), however, that appears to have the same results. Please advise.

    # garbd -a gcomm://192.168.128.203 -g mycluster -o gmcast.listen_addr=tcp://192.168.128.75
    2014-03-14 01:43:27.549 INFO: CRC-32C: using hardware acceleration.
    2014-03-14 01:43:27.549 INFO: Read config:
    daemon: 0
    name: garb
    address: gcomm://192.168.128.203
    group: mycluster
    sst: trivial
    donor:
    options: gmcast.listen_addr=tcp://192.168.128.75; gcs.fc_limit=9999999; gcs.fc_factor=1.0; gcs.fc_master_slave=yes
    cfg:
    log:

    2014-03-14 01:43:27.550 INFO: protonet asio version 0
    2014-03-14 01:43:27.551 INFO: Using CRC-32C (optimized) for message checksums.
    2014-03-14 01:43:27.551 INFO: backend: asio
    2014-03-14 01:43:27.552 INFO: GMCast version 0
    terminate called after throwing an instance of 'gu::NotSet'
    Aborted

  • #2
    Got exactly the same problem today (same version)

    Comment


    • #3
      Hi, Try and set: -o gmcast.listen_addr=tcp://0.0.0.0:4567 instead.
      Best regards ,
      Johan
      Last edited by scott.nemes; 03-15-2014, 03:36 PM. Reason: Ad

      Comment


      • #4
        No change for me ... same error

        Comment


        • #5
          Doesn't work for me either, still same error.
          # garbd -a gcomm://192.168.128.203 -g mycluster -o gmcast.listen_addr=tcp://0.0.0.0:4567
          2014-03-27 17:12:56.131 INFO: CRC-32C: using hardware acceleration.
          2014-03-27 17:12:56.131 INFO: Read config:
          daemon: 0
          name: garb
          address: gcomm://192.168.128.203
          group: mycluster
          sst: trivial
          donor:
          options: gmcast.listen_addr=tcp://0.0.0.0:4567; gcs.fc_limit=9999999; gcs.fc_factor=1.0; gcs.fc_master_slave=yes
          cfg:
          log:

          2014-03-27 17:12:56.132 INFO: protonet asio version 0
          2014-03-27 17:12:56.132 INFO: Using CRC-32C (optimized) for message checksums.
          2014-03-27 17:12:56.132 INFO: backend: asio
          2014-03-27 17:12:56.133 INFO: GMCast version 0
          terminate called after throwing an instance of 'gu::NotSet'
          Aborted

          Comment


          • #6
            Originally posted by jhtran View Post
            Doesn't work for me either, still same error.
            # garbd -a gcomm://192.168.128.203 -g mycluster -o gmcast.listen_addr=tcp://0.0.0.0:4567
            2014-03-27 17:12:56.131 INFO: CRC-32C: using hardware acceleration.
            2014-03-27 17:12:56.131 INFO: Read config:
            daemon: 0
            name: garb
            address: gcomm://192.168.128.203
            group: mycluster
            sst: trivial
            donor:
            options: gmcast.listen_addr=tcp://0.0.0.0:4567; gcs.fc_limit=9999999; gcs.fc_factor=1.0; gcs.fc_master_slave=yes
            cfg:
            log:

            2014-03-27 17:12:56.132 INFO: protonet asio version 0
            2014-03-27 17:12:56.132 INFO: Using CRC-32C (optimized) for message checksums.
            2014-03-27 17:12:56.132 INFO: backend: asio
            2014-03-27 17:12:56.133 INFO: GMCast version 0
            terminate called after throwing an instance of 'gu::NotSet'
            Aborted
            Ran into the same problem. For me it worked when i added port to the address (-a), i.e.:
            # garbd -a gcomm://192.168.128.203:4567 -g mycluster -o gmcast.listen_addr=tcp://0.0.0.0:4567

            Comment


            • #7
              Hello
              I think it was a problem of dependancy with the package...

              Install the complete percona packages seems to solve the problem

              apt-get install percona-xtradb-cluster-server-5.5 percona-xtradb-cluster-client-5.5 percona-xtradb-cluster-galera-2.x

              For me it works this way

              Comment

              Working...
              X