GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

Unable to start first node of cluster.

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Unable to start first node of cluster.

    Complete Percona newbie, so have some patience :-)

    I've installed the Percona Server software on 3 Centos nodes (version 5.6).
    After that, I installed the Cluster software (version 5.5) - most of that seemed to be already included in the server software.
    Next step : adapt the my.cnf file according to http://www.percona.com/doc/percona-x...ots_howto.html

    Now, when I try to start the first node with
    /etc/init.d/mysql start --wsrep_cluster_address="gcomm://"

    I get :
    Starting MySQL (Percona Server)... ERROR! The server quit without updating PID file

    and the mysql log file says :
    ...
    2014-01-27 14:55:23 9723 [Note] InnoDB: Percona XtraDB (http://www.percona.com) 5.6.15-rel63.0 started; log sequence number 1626027
    2014-01-27 14:55:23 9723 [ERROR] /usr/sbin/mysqld: unknown variable 'wsrep-cluster-address=gcomm://'
    2014-01-27 14:55:23 9723 [ERROR] Aborting
    ...

    What have I missed ?

    regards
    Jo

  • #2
    What do you mean by installed the Percona Server software on 3 Centos nodes (version 5.6) and then installed cluster software version 5.5 ? Did you installed both Percona Server and Percona XtraDB Cluster ?
    Can you show me the output of

    $ rpm -qa | grep -i "percona"

    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Hi mirfan

      the output is :

      [root@553579-srv115 ~]# rpm -qa | grep -i "percona"
      percona-release-0.0-1.x86_64
      Percona-XtraDB-Cluster-galera-2-2.8-1.157.rhel6.x86_64
      Percona-Server-shared-56-5.6.15-rel63.0.519.rhel6.x86_64
      Percona-Server-server-56-5.6.15-rel63.0.519.rhel6.x86_64
      percona-xtrabackup-2.1.7-721.rhel6.x86_64
      Percona-Server-client-56-5.6.15-rel63.0.519.rhel6.x86_64


      regards
      Jo

  • #3
    @holvoetj,
    The error clearly says there is a typo in 'wsrep-cluster-address=gcomm://' the variable should be wsrep_cluster_address and not wsrep-cluster-address

    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Hi madhusudan,

      my command line used underscores but the error message uses hyphens. It doesn't work with either one.

      regards
      Jo

  • #4
    u should put that in correct my.cnf file, check to see which my.cnf file its using while its starting..! (usually /etc/my.cnf or /etc/mysql/my.cnf) cross check with these files.

    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Hi madhusudan,

      I only have one my.cnf on the server (/etc/my.cnf)

      regards
      Jo

  • #5
    What's the output of /usr/sbin/mysqld --verbose --help | grep -A 1 "Default options" ?

    and also do a grep of "wsrep-cluster-address" on all .cnf files.
    somewhere its present!, you have to remove it.



    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Here you go :

      [root@553579-srv115 ~]# /usr/sbin/mysqld --verbose --help 2>&1 | grep -A 1 "Default options"
      Default options are read from the following files in the given order:
      /etc/my.cnf /etc/mysql/my.cnf /usr/etc/my.cnf ~/.my.cnf

      [root@553579-srv115 ~]# ls -l /etc/my.cnf /etc/mysql/my.cnf /usr/etc/my.cnf ~/.my.cnf
      ls: cannot access /etc/mysql/my.cnf: No such file or directory
      ls: cannot access /usr/etc/my.cnf: No such file or directory
      ls: cannot access /root/.my.cnf: No such file or directory
      -rw-r--r-- 1 root root 1279 Jan 29 11:03 /etc/my.cnf


      regards
      Jo

  • #6
    have u looked into that /etc/my.cnf file clearly for wsrep-cluster-address..?

    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Yes :-)
      only underscores ...

      regards
      Jo

  • #7
    Strange!!, only way to find is, do a grep on entire system!.. it will take time but u will get the culprit... :-)

    find / -exec grep -l "wsrep-cluster-address" {} \;

    for quicker search
    find / -name "*.cnf" -exec grep -l "wsrep-cluster-address" {} \;




    Last edited by madhusudan; 01-30-2014, 05:24 AM.

    Comment


    • holvoetj
      holvoetj commented
      Editing a comment
      Hi madhusudan,

      I gave up :-) and started from scratch.

      1. I made sure "yum list" and "rpm -qa" listed nothing installed from percona or mysql
      2. then ran "yum install Percona-XtraDB-Cluster-server-56" (last time I tried version 5.5)
      3. Created the file /etc/my.cnf with the contents of http://www.percona.com/doc/percona-x...l#centos-howto
      4. Started it up with /etc/init.d/mysql start --wsrep-cluster-address="gcomm://"

      output :

      [root@553579-srv115 ~]# /etc/init.d/mysql start --wsrep-cluster-address="gcomm://"
      Starting MySQL (Percona XtraDB Cluster). SUCCESS!

      I can only imagine I had a conflict somewhere with packages installed earlier by someone else ...

      Many, many thanks for all your help !

      regards
      Jo
Working...
X