Announcement

Announcement Module
Collapse
No announcement yet.

Dependencies missing for percona 5.6

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Dependencies missing for percona 5.6

    I am trying to upgrade from 5.5 to 5.6 using Fedora 17 64bit. I am getting the following:
    Error: Package: 1:Percona-XtraDB-Cluster-server-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: 1:Percona-XtraDB-Cluster-server-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: Percona-XtraDB-Cluster-shared-56
    Error: Package: 1:Percona-XtraDB-Cluster-client-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: 1:Percona-XtraDB-Cluster-server-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: libcrypto.so.10(libcrypto.so.10)(64bit)
    Error: Package: 1:Percona-XtraDB-Cluster-client-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: libssl.so.10(libssl.so.10)(64bit)
    Error: Package: 1:Percona-XtraDB-Cluster-server-56-5.6.15-25.2.645.rhel6.x86_64 (ExpoSecondaryRepo)
    Requires: Percona-XtraDB-Cluster-galera-25
    You could try using --skip-broken to work around the problem
    You could try running: rpm -Va --nofiles --nodigest


    I am using a custom repo that has the RPMs.
    I installed openssl098e and did the following:
    [root:data]$ find / -name libcrypto.so.10
    /usr/lib64/libcrypto.so.10
    [root:data]$ find / -name libssl.so.10
    /usr/lib64/libssl.so.10

    Any help would be appreciated.
    Last edited by gzion7; 01-15-2014, 12:53 PM.

  • #2
    My suggestion would be to stick to 5.5, as 5.6 is not stable yet (I tried on my Ubuntu and got lot of problems...)

    Comment


    • #3
      I got it working on Fedora17

      Here is a summary:
      - wget https://archive.fedoraproject.org/pu...c18.x86_64.rpm
      - sudo rpm -ihv --replacefiles openssl-libs-1.0.1e-36.fc18.x86_64.rpm
      - sudo rpm -ihv --replacefiles Percona-XtraDB-Cluster-*

      Comment


      • #4
        Thanks, I'll try that.

        Comment

        Working...
        X