GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

HAProxy / node 3 doesn't respond

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • HAProxy / node 3 doesn't respond

    Hi every body,


    I try to do xtradbcluster whith HA Proxy. I have 3 node for the cluster. When I cut service mysql on third node, I d'ont have any response by haproxy.

    This is the configuration of haproxy :

    listen MySQL 0.0.0.0:3306
    timeout connect 10s
    timeout client 1m
    timeout server 1m
    balance roundrobin
    mode tcp
    option mysql-check user haproxy
    server node1 172.16.66.61:3306 check
    server node2 172.16.66.62:3306 check
    server node3 172.16.66.63:3306 check


    And the configuration of node1 for exemple :

    [mysqld]

    datadir=/var/lib/mysql
    user=mysql

    auto_increment_offset = 4
    auto_increment_increment = 4

    # Path to Galera library
    wsrep_provider=/usr/lib64/libgalera_smm.so

    # Cluster connection URL contains the IPs of node#1, node#2 and node#3
    wsrep_cluster_address=gcomm://172.16.66.61,172.16.66.62,172.16.66.63

    # In order for Galera to work correctly binlog format should be ROW
    binlog_format=ROW

    # MyISAM storage engine has only experimental support
    default_storage_engine=InnoDB

    # This is a recommended tuning variable for performance
    innodb_locks_unsafe_for_binlog=1

    # This changes how InnoDB autoincrement locks are managed and is a requirement for Galera
    innodb_autoinc_lock_mode=2

    # Node #1 address
    wsrep_node_address=172.16.66.61

    # SST method
    wsrep_sst_method=xtrabackup

    # Cluster name
    wsrep_cluster_name=my_centos_cluster

    # Authentication for SST method
    wsrep_sst_auth="sstuser:s3cret"


    # Customisation
    tmp_table_size = 32M
    max_heap_table_size = 32M
    slow_query_log=1
    long_query_time=1

    query_cache_limit = 2M
    query_cache_size = 32M


    Have you got any idea to know what happen ? or any help to know what happen ?

    All node id up and I can red/write data on any node. Replication is ok between all node. Mysql client connection on all node is ok.

    But mysql client connection on haproxy when node 1 and node 2 mysql services is down, I have this responses : ERROR 2013 (HY000): Lost connection to MySQL server at 'reading initial communication packet', system error: 0

    Thanks a lot for your help ....

    ps : I knows My network is a Satan's network 172 .16.66.0/24




  • #2
    I solve the problem : delete server node 3 and create new node.

    Comment

    Working...
    X