Announcement

Announcement Module
Collapse
No announcement yet.

innobackupex: --defaults-file=/etc/my.cnf: not found

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • innobackupex: --defaults-file=/etc/my.cnf: not found

    Hi.
    I get an error after executing the following command:

    innobackupex --defaults-file=/etc/my.cnf --user=root --password=xxxx --slave-info --databases="test" --stream=tar /var/tmp/

    ....
    innobackupex: Using mysql Ver 14.14 Distrib 5.6.10, for FreeBSD9.0 (amd64) using 5.2
    Warning: Using a password on the command line interface can be insecure.
    innobackupex: Using mysql server version Copyright (c) 2000, 2013, Oracle and/or its affiliates. All rights reserved.
    --defaults-file=/etc/my.cnf: not found
    innobackupex: fatal error: no 'mysqld' group in MySQL options


    # cat /etc/my.cnf
    [mysqld]
    datadir=/var/db/mysql
    default-storage-engine=innodb
    innodb_buffer_pool_size=256M
    innodb_flush_log_at_trx_commit=1
    innodb_file_per_table=1
    max_connections=200


    # uname -a
    FreeBSD 9.0-RELEASE FreeBSD 9.0-RELEASE #0: Tue Jan 3 07:46:30 UTC 2012 [EMAIL="root@farrell.cse.buffalo.edu"]root@farrell.cse.buffalo.edu[/EMAIL="root@farrell.cse.buffalo.edu"]:/usr/obj/usr/src/sys/GENERIC amd64


    # pkg_info | grep xtrabackup
    xtrabackup-2.0.3 OpenSource version of InnoDB backup with support of Percona


    # pkg_info | grep mysql
    mysql-client-5.6.10 Multithreaded SQL database (client)
    mysql-server-5.6.10 Multithreaded SQL database (server)


    What is my mistake?
    Last edited by stefank; 04-23-2013, 11:09 AM.

  • #2
    Check your log files, especially apparmor.

    Comment


    • #3
      Sorry, but where can I find the xtrabackup logs?
      There are no new log messages in
      /var/log/*
      /var/db/mysql/*

      Comment


      • #4
        apparmor should log somewhere under /var/log/*

        I have found an old bug report: https://bugs.launchpad.net/percona-x...up/+bug/359341

        Odd, it should have been fixed.

        Comment


        • #5
          My mistake was, that I used mysql-server 5.6
          I downgraded to 5.5 and it works.

          Comment

          Working...
          X