Announcement

Announcement Module
Collapse
No announcement yet.

Missing mysql and performance_schema files after apply-log

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Missing mysql and performance_schema files after apply-log

    Sometimes the mysql and performance_schema directory contents get deleted when I do the prepare/apply-log. I have not been able to figure out what I am doing wrong, It seems random, I ran the same commands two days earlier with no issues.

    [root@applepie FUL]# innobackupex --slave-info /backup/30DAY/Applepie/FUL/
    [root@Applepie FUL]# ll /backup/30DAY/applepie/FUL/2013-04-09_13-56-05/mysql/
    total 3740
    -rwxrwx--- 1 27 27 8820 Apr 9 13:22 columns_priv.frm
    -rwxrwx--- 1 27 27 0 Apr 9 13:22 columns_priv.MYD
    ...
    -rwxrwx--- 1 27 27 10630 Apr 9 13:22 user.frm
    -rwxrwx--- 1 27 27 684 Apr 9 13:22 user.MYD
    -rwxrwx--- 1 27 27 2048 Apr 9 13:22 user.MYI
    [root@applepie FUL]# ll /backup/30DAY/applepie/FUL/2013-04-09_13-56-05/performance_schema/
    total 867
    -rwxrwx--- 1 27 27 8624 Apr 9 13:29 cond_instances.frm
    -rwxrwx--- 1 27 27 61 Apr 9 13:29 db.opt
    ...
    -rwxrwx--- 1 27 27 8650 Apr 9 13:29 setup_timers.frm
    -rwxrwx--- 1 27 27 8650 Apr 9 13:29 threads.frm

    [root@applepie FUL]# innobackupex --apply-log /backup/30DAY/Applepie/FUL/2013-04-09_13-56-05
    [root@applepie FUL]# ll /backup/30DAY/applepie/FUL/2013-04-09_13-56-05/mysql/
    total 0
    [root@applepie FUL]# ll /backup/30DAY/applepie/FUL/2013-04-09_13-56-05/performance_schema/
    total 0

  • #2
    I can't find any bug or question similar to the problem you are having. Can you please attach the full backup and apply logs?

    Thank you,

    Comment


    • #3
      I talked to Percona folks at Percona live. User error - I was doing xtrabackup not innoBaqckupex

      Comment

      Working...
      X