Announcement

Announcement Module
Collapse
No announcement yet.

Possible Bug : INNODB=FORCE ambiguous option

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • Possible Bug : INNODB=FORCE ambiguous option

    I am testing using xtrabackup and ran into an issue. I am using xtrabackup version 2.0.2 on a Centos 6.2 server running Percona Server 5.5.22-55-log Percona Server (GPL), Release rel25.2, Revision 237.

    My my.cnf contains the following

    innodb = FORCE


    When I try a backup I get the following:

    [root@chef-test-mysql-db-02 ~]# innobackupex --user=ignbackup --password= /var/lib/mysql/backups/InnoDB Backup Utility v1.5.1-xtrabackup; Copyright 2003, 2009 Innobase Oyand Percona Inc 2009-2012. All Rights Reserved.This software is published underthe GNU GENERAL PUBLIC LICENSE Version 2, June 1991.120911 13:47:44 innobackupex: Starting mysql with options: --password=xxxxxxxx --user='ignbackup' --unbuffered --120911 13:47:44 innobackupex: Connected to database with mysql child process (pid=13513)120911 13:47:50 innobackupex: Connection to database server closedIMPORTANT: Please check that the backup run completes successfully. At the end of a successful backup run innobackupex prints "completed OK!".innobackupex: Using mysql Ver 14.14 Distrib 5.5.22, for Linux (x86_64) using readline 5.1innobackupex: Using mysql server version Copyright (c) 2000, 2011, Oracle and/or its affiliates. All rights reserved.xtrabackup_55: ambiguous option '--innodb=FORCE' (innodb_adaptive_hash_index, innodb_doublewrite_file)innobackupex: fatal error: no 'mysqld' group in MySQL options


    When do a print param I get this:

    [root@chef-test-mysql-db-02 ~]# xtrabackup --defaults-file=/etc/my.cnf --print-paramxtrabackup: ambiguous option '--innodb=FORCE' (innodb_adaptive_hash_index, innodb_doublewrite_file)


    If I comment out that line from my my.cnf it works fine.

    Allen

  • #2
    Hi Allen,

    It seems, you are hitting this bug. https://bugs.launchpad.net/percona-x...up/+bug/528752
    As It's not fixed yet, you can use workaround for now by adding "loose-innodb=force" in my.cnf.

    Thanks.

    Comment

    Working...
    X