GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

xtrabackup segmentation fault

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup segmentation fault

    Hello

    I am trying to update xtrabackup from 1.6.3 to 1.6.5 on a Debian etch. Using compiled AMD64 binary I am getting segmentation fault and now I am trying to compile it myself.

    To compile I am using the next:
    AUTO_DOWNLOAD="yes" ./utils/build.sh innodb51

    This command is described in BUILD.txt and the option innodb51 is the correct for my installed mysql server.

    The problem is that if I use this compilation option I get:
    Build an xtrabackup binary against the specified InnoDB flavor.

    Usage: build.sh CODEBASE
    where CODEBASE can be one of the following values or aliases:
    innodb51_builtin | 5.1 build against built-in InnoDB in MySQL 5.1
    innodb55 | 5.5 build against InnoDB in MySQL 5.5
    xtradb51 | xtradb build against Percona Server with XtraDB 5.1
    xtradb55 | xtradb55 build against Percona Server with XtraDB 5.5

    So no option to InnoDB plugin but it is documented in BUILD.txt

    Is there any way to have last version of xtrabackup on Debian etch ? My server has libc6 2.3.6, is the version a problem ?

    ldd output of precompiled binary:
    ldd xtrabackup_51
    libpthread.so.0 => /lib/libpthread.so.0 (0x00002b9f97f12000)
    libc.so.6 => /lib/libc.so.6 (0x00002b9f98027000)
    /lib64/ld-linux-x86-64.so.2 (0x00002b9f97dfa000)

    I have another Debian server with libc6 version 2.7-18, and ldd output is (in this version seems to work):
    ldd xtrabackup_51
    linux-vdso.so.1 => (0x00007fff161ff000)
    libpthread.so.0 => /lib/libpthread.so.0 (0x00007f879eba6000)
    libc.so.6 => /lib/libc.so.6 (0x00007f879e853000)
    /lib64/ld-linux-x86-64.so.2 (0x00007f879edc2000)

  • #2
    Part of documentation (BUILD.txt) that mention innodb plugin compilation option:
    The script needs the codebase for which the building is targeted, you must
    provide it with one of the following values or aliases:

    ================== ========= =============================================
    Value Alias Server
    ================== ========= =============================================
    innodb51_builtin 5.1 build against built-in InnoDB in MySQL 5.1
    innodb51 plugin build agsinst InnoDB plugin in MySQL 5.1
    innodb55 5.5 build against InnoDB in MySQL 5.5
    xtradb51 xtradb build against Percona Server with XtraDB 5.1
    xtradb55 xtradb55 build against Percona Server with XtraDB 5.5
    ================== ========= =============================================

    Also you could read at online do:
    http://www.percona.com/doc/percona-xtrabackup/installation/c ompiling_xtrabackup.html?id=percona-xtrabackup:installation: from-source&redirect=1

    Comment

    Working...
    X