GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

innobackupex do not support \G syntax

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • innobackupex do not support \G syntax

    The innobackupex will be error when it running on the source compiled mysql version. The error list following:

    120316 15:06:23 innobackupex: Starting mysql with options: --defaults-file='/etc/my.cnf' --password=xxxxxxxx --user='root' --unbuffered --
    120316 15:06:23 innobackupex: Connected to database with mysql child process (pid=10046)
    innobackupex: Error: mysql child process has died: ERROR 1064 (42000) at line 3: You have an error in your SQL syntax; check the manual that corresponds to your MySQL server version for the right syntax to use near '\G
    select 'xtrabackup ping 2'' at line 1
    while waiting for reply to MySQL request: 'SHOW VARIABLES LIKE 'version'\G' at /usr/bin/innobackupex line 371.

    Is there any suggestions which make the mysql server support
    '\G' syntax? Any opinion or suggestions are very appreciated!

  • #2
    It has supported that syntax since the year 0. Something strange is probably happening, such as an odd SQL_MODE setting that xtrabackup is violating.

    Comment

    Working...
    X