Announcement

Announcement Module
Collapse
No announcement yet.

running XtraBackup under windows.

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • running XtraBackup under windows.

    Hi Folks,

    Hope you can provide some guidance getting the backup working on a windows machine. I know it's still in alpha, so i expect to hit a few snags along the way.

    So i have install :
    5.1.46-community
    running windows 7 pro
    Version 6.1.7601 Service Pack 1 Build 7601
    downloaded the xtrabackup-1.6.64bit.zip

    I'm running the following command :

    C:\ProgramData\MySQL\MySQL Server 5.1\data>C:\xtrabackup-1.6.64bit\xtrabackup --
    backup --datadir="C:\ProgramData\MySQL\MySQL Server 5.1\data" --target-dir="c:\t
    emp\mysql" --defaults-file="C:\Program Files (x86)\MySQL\MySQL Server 5.1\my.ini"

    the output is so :
    xtrabackup: cd to C:\ProgramData\MySQL\MySQL Server 5.1\data
    xtrabackup: Target instance is assumed as followings.
    xtrabackup: innodb_data_home_dir = .\
    xtrabackup: innodb_data_file_path = ibdata1:10M:autoextend
    xtrabackup: innodb_log_group_home_dir = .\
    xtrabackup: innodb_log_files_in_group = 2
    xtrabackup: innodb_log_file_size = 5242880
    InnoDB: Error: log file .\ib_logfile0 is of different size 0
    InnoDB: than specified in the .cnf file 0 5242880 bytes!

    I'm able to startup mysql with out any issues of inconsistency, so i gather that the issue is that it's not finding the correct configuration file.

    Some help would be greatly appreciated.

  • #2
    Please file a bug in the percona-xtrabackup Launchpad project.

    Comment


    • #3
      Hello there,

      I do have the same problem.
      Is it really a bug?
      If yes, how can I check the fix?

      Best regards

      Lanenet

      Comment

      Working...
      X