GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

innobackupex-1.5.1 error in backup

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • innobackupex-1.5.1 error in backup

    Hi,
    Im trying to get a full backup from my db's in my slave server and im using :

    $ innobackupex-1.5.1 --slave-info /mnt/data/tmp

    and always in the same point show this error :
    [01] Copying ./emails/mail_pending_childrens#P#p47.ibd
    to /mnt/data/tmp/2011-04-26_12-30-02/emails/mails_pending_child rens#P#p47.ibd
    [01] ...done
    110426 12:45:11 InnoDB: Operating system error number 24 in a file operation.
    InnoDB: Error number 24 means 'Too many open files'.
    InnoDB: Some operating system error numbers are described at
    InnoDB: http://dev.mysql.com/doc/refman/5.1/en/operating-system-erro r-codes.html
    InnoDB: File name /mnt/data/tmp/2011-04-26_12-30-02/emails/mails_pending_child rens#P#p48.ibd
    InnoDB: File operation call: 'create'.
    110426 12:45:11 InnoDB: Operating system error number 24 in a file operation.
    InnoDB: Error number 24 means 'Too many open files'.
    InnoDB: Some operating system error numbers are described at
    InnoDB: http://dev.mysql.com/doc/refman/5.1/en/operating-system-erro r-codes.html
    [01] xtrabackup: error: cannot open /mnt/data/tmp/2011-04-26_12-30-02/emails/mails_pending_child rens#P#p48.ibd
    [01] xtrabackup: Error: xtrabackup_copy_datafile() failed.
    [01] xtrabackup: Warning: failed to copy, but continuing.
    110426 12:45:11 InnoDB: Operating system error number 24 in a file operation.
    InnoDB: Error number 24 means 'Too many open files'.
    InnoDB: Some operating system error numbers are described at
    InnoDB: http://dev.mysql.com/doc/refman/5.1/en/operating-system-erro r-codes.html
    110426 12:45:11 InnoDB: Fatal error: cannot open ./emails/mails_pending_childrens#P#p49.ibd
    .InnoDB: Have you deleted .ibd files under a running mysqld server?
    110426 12:45:11 InnoDB: Assertion failure in thread 1455479104 in file fil/fil0fil.c line 675
    InnoDB: Failing assertion: 0
    InnoDB: We intentionally generate a memory trap.
    InnoDB: Submit a detailed bug report to http://bugs.mysql.com.
    InnoDB: If you get repeated assertion failures or crashes, even
    InnoDB: immediately after the mysqld startup, there may be
    InnoDB: corruption in the InnoDB tablespace. Please refer to
    InnoDB: http://dev.mysql.com/doc/refman/5.1/en/forcing-recovery.html
    InnoDB: about forcing recovery.
    innobackupex-1.5.1: Error: ibbackup child process has died at /usr/bin/innobackupex-1.5.1 line 542.

    This is some lines in the my.cnf file :
    # InnoDB Settings
    innodb_file_per_table
    innodb_data_home_dir = /mnt/data/innodb/
    innodb_data_file_path = dbdata01:750M:autoextend
    innodb_log_group_home_dir = /mnt/data/logs/
    innodb_buffer_pool_size = 50G
    innodb_additional_mem_pool_size = 100M
    innodb_log_file_size = 100M
    innodb_log_buffer_size = 6M
    innodb_flush_log_at_trx_commit = 2
    innodb_lock_wait_timeout = 60
    innodb_thread_concurrency = 0
    innodb_support_xa = 1
    innodb_rollback_on_timeout = 1
    innodb_flush_method = O_DIRECT
    innodb_open_files = 5000
    innodb_read_ahead = linear
    innodb_read_io_threads = 24
    innodb_write_io_threads = 8
    innodb_file_format = Barracuda

    Any ideas?

  • #2
    You need to increase ulimit -n for the backup user.

    Comment


    • #3
      Hi, i already changed to double my limits with ulimit -n ###, but its stuck in the same part with the same ptoblem .. here what i changed

      [root@FNM security]# ulimit -a
      core file size (blocks, -c) 0
      data seg size (kbytes, -d) unlimited
      scheduling priority (-e) 0
      file size (blocks, -f) unlimited
      pending signals (-i) 999424
      max locked memory (kbytes, -l) 32
      max memory size (kbytes, -m) unlimited
      open files (-n) 2048 <-- Before 1024
      pipe size (512 bytes, -p) 8
      POSIX message queues (bytes, -q) 819200
      real-time priority (-r) 0
      stack size (kbytes, -s) 10240
      cpu time (seconds, -t) unlimited
      max user processes (-u) unlimited
      virtual memory (kbytes, -v) unlimited
      file locks (-x) unlimited

      Comment


      • #4
        Done... i just play with the numbers and finally ulimit -n 4096 was the solution... thanks!

        Comment


        • #5
          1024, 2048, even 4096 is TINY. Just set it to unlimited. Seriously -- a filehandle is such a trivially cheap resource for the operating system to maintain that there is no sense limiting them.

          Comment

          Working...
          X