Announcement

Announcement Module
Collapse
No announcement yet.

MariaDB 5.2.4-94 and xtrabackup 1.5-9

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • MariaDB 5.2.4-94 and xtrabackup 1.5-9

    Hi ^^

    I have a server (fedora 14) with MySQL 5.1.52-1 and xtrabackup 1.5-9 working.
    I only had to change line 1719 :
    if (substr($^V,1) lt $perl_version) {
    since $^V is v.num_version and not num_version

    Now, on a laptop (fedora 14), I switched to MariaDB 5.2.4-94 and I have a few more errors :

    Use of uninitialized value $option_ibbackup_binary in concatenation (.) or string at /usr/bin/innobackupex-1.5.1 line 2140.Can't exec "--print-param": Aucun fichier ou dossier de ce type at /usr/bin/innobackupex-1.5.1 line 2141.innobackupex-1.5.1: fatal error: no 'mysqld' group in MySQL optionsinnobackupex-1.5.1: fatal error: OR no 'datadir' option in group 'mysqld' in MySQL options


    Does somebody have an idea why xtrabackup does this ?

    EDIT : Forgot to say I use xtrabackup RHEL5/x86_64
Working...
X