GET 24/7 LIVE HELP NOW

Announcement

Announcement Module
Collapse
No announcement yet.

xtrabackup child process has died at /usr/bin/innobackupex line 2622.

Page Title Module
Move Remove Collapse
X
Conversation Detail Module
Collapse
  • Filter
  • Time
  • Show
Clear All
new posts

  • xtrabackup child process has died at /usr/bin/innobackupex line 2622.

    Hi,

    I'm using XtraBackup 2.1.8 installed using Percona RPMs on RHEL 6.5 x86_64 to stream a backup to another server through ssh using tar method. Previous backups run with the same script were successfull, but the last backup crashed with the following error:

    innobackupex: Error: The xtrabackup child process has died at /usr/bin/innobackupex line 2622.

    Line 2622 of /usr/bin/innobackupex is:
    die "The xtrabackup child process has died";

    How can I get the logs from xtrabackup ? Is there a way to determine why the backup failed ?

    Regards,
    Laurent.

  • #2
    Hi,

    Without log its really difficult to find out the root cause. If you are taking backup through script, why don't you collect the log in separate file for each backup. You can remove it if backup is successful otherwise it can be helpful to find out the cause of backup failure.

    Comment


    • #3
      I have the same issue. here's the log entry:

      xtrabackup: error: log block numbers mismatch:
      xtrabackup: error: expected log block no. 940838868, but got no. 949227472 from the log file.
      xtrabackup: Error: xtrabackup_copy_logfile() failed.
      innobackupex: Error: The xtrabackup child process has died at /home/mysql/xtrabackup/bin/innobackupex line 2622.

      The system is under load while the backup is taken

      Comment


      • #4
        Mysql version 5.6.17. xtrabackup version is 2.1.8

        Comment


        • #5
          Hi bhblack,

          There were some bugs related to this issue. "xtrabackup: error: log block numbers mismatch" i.e
          https://bugs.launchpad.net/percona-x...up/+bug/917823
          https://bugs.launchpad.net/percona-x...p/+bug/1206309

          This is generally happening with heavy load on the server means log copying being too slow, or log files being too small. Can you try to increase log file size and check?
          Have you tried to use latest version of Xtrabackup (2.2) ?
          If you still facing the same issue then you should rather re-open that bug with all required details.

          Comment

          Working...
          X